summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Linke <particleflux@gmail.com>2023-09-24 15:03:30 +0200
committerSam James <sam@gentoo.org>2023-09-25 03:32:51 +0100
commit2743b32d1fb07494f909c8f6efc78d1782bb4295 (patch)
treeed4a482a0d4fb7be068493a80638d20aca5635b1 /dev-php
parentsys-devel/gcc: remove unused patch (diff)
downloadgentoo-2743b32d1fb07494f909c8f6efc78d1782bb4295.tar.gz
gentoo-2743b32d1fb07494f909c8f6efc78d1782bb4295.tar.bz2
gentoo-2743b32d1fb07494f909c8f6efc78d1782bb4295.zip
dev-php/xdebug: add 3.2.1
Closes: https://bugs.gentoo.org/893758 Signed-off-by: Stefan Linke <particleflux@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33032 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug/Manifest1
-rw-r--r--dev-php/xdebug/xdebug-3.2.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-php/xdebug/Manifest b/dev-php/xdebug/Manifest
index 156ef2298090..9add28f80792 100644
--- a/dev-php/xdebug/Manifest
+++ b/dev-php/xdebug/Manifest
@@ -1,3 +1,4 @@
DIST xdebug-3.1.1.tar.gz 468120 BLAKE2B 038774612158c2c9b406e29dd70e2a3e182ce121bc92036eeb3362be0ba513a223cb2da41bdfe914d6861ae9d94ff33c5301cc23725ee771f47876c8095ae0b8 SHA512 b91bca3bac184723b3f6dc0c5db012f2ec0895ed55cd4ff83f73d35462b9cea654476c848f7d61559a4bd8661ce335fc71a45a7cab1165f4197d265e31eccc71
DIST xdebug-3.1.3.tar.gz 470305 BLAKE2B abc799f966c20ba868d57e707ebc35e1f2d4ef5567bcd373ae5ae2ada58fbd4a4a807cfdf520cb883f08bc5296f219d190865462eab7d11ff2cb8c12a33b671b SHA512 cd2e85ce37f5122bcaa8300061be3b244bf9a58060e4e7286b3b52e9ab592f9a8ad43b62d53f13c7be878bb8662ff7aba187b73040bea79a3244df3d6b59e27b
DIST xdebug-3.1.5.tar.gz 434440 BLAKE2B e9a94ff8d774ed55c848a6e3933064ab6ea91db6b70f9aaed206296152ec2bc7e15b6330ea166bf9bc5fa26ff0c2a0bf8accd281ad833318b9b718d6f7d671a4 SHA512 6949d98cdf67c5931f1abfac1a2a8ea95123431dc57325fe5005c445f4f87fd461ce4eadde41f45d2e3fd4d63c0e4ae952954eae4f86d78c498f95ce43b49e81
+DIST xdebug-3.2.1.tar.gz 450198 BLAKE2B 046120555bc6ff5b15380618c8126387eec213036299dfaefd2d8bca77c625c064dec938f56d665aae479c7fd76a9fdcc0304695f8ec44534d0a5265d9073159 SHA512 c7246e8cf7dc22b9c21ec1586fc5393817b1b5eefff9339652846340a6cc57fa72adb6c9229a87ac9849e8f5762aafbf140d99d0978950e93562e228d9da5a6b
diff --git a/dev-php/xdebug/xdebug-3.2.1.ebuild b/dev-php/xdebug/xdebug-3.2.1.ebuild
new file mode 100644
index 000000000000..68031eaf22da
--- /dev/null
+++ b/dev-php/xdebug/xdebug-3.2.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+PHP_EXT_INIFILE="3.0-xdebug.ini"
+
+USE_PHP="php8-0 php8-1 php8-2"
+PHP_EXT_NEEDED_USE="-threads(-)"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="https://xdebug.org/"
+# Using tarball from GitHub for tests
+#SRC_URI="https://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+SRC_URI="https://github.com/xdebug/xdebug/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+# Tests are known to fail
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+DOCS=( README.rst CREDITS )
+PHP_EXT_ECONF_ARGS=()
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ TEST_PHP_EXECUTABLE="${PHPCLI}" \
+ TEST_PHP_CGI_EXECUTABLE="${PHPCGI}" \
+ TEST_PHPDBG_EXECUTABLE="${PHPCLI}dbg" \
+ "${PHPCLI}" run-xdebug-tests.php
+ done
+}
+
+pkg_postinst() {
+ ewarn "We have set xdebug.mode to off, as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.mode to one or more modes e.g. develop,debug,trace"
+ elog ""
+ elog "The 3.0 major release changes many options."
+ elog "Review https://xdebug.org/docs/upgrade_guide for differences from 2.x"
+}