summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-04-08 15:22:28 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-04-08 15:27:24 -0400
commit9e356729a0b908d7f622199c469826a9ec1efea1 (patch)
tree4352eba0e6622907b9050b7f58e04202e4ddef50 /dev-php/pecl-ssh2
parentdev-php/pecl-ssh2: add php-7.1 support. (diff)
downloadgentoo-9e356729a0b908d7f622199c469826a9ec1efea1.tar.gz
gentoo-9e356729a0b908d7f622199c469826a9ec1efea1.tar.bz2
gentoo-9e356729a0b908d7f622199c469826a9ec1efea1.zip
dev-php/pecl-ssh2: new v0.13 revision supporting PHP_TARGETS=php7-1.
The SLOT=0 for this package supports php-5.x, while SLOT=7 supports php-7.x. To get them both installed at the same time, we use some weird trickery. Long story short, we need to add a special case to the SLOT=0 ebuild supporting "php7-1" in PHP_TARGETS. The previous commit added php-7.1 support to the SLOT=7 ebuilds, and this commit adds it to the SLOT=0 ebuild. Gentoo-Bug: 603508 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php/pecl-ssh2')
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild (renamed from dev-php/pecl-ssh2/pecl-ssh2-0.13-r1.ebuild)12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-0.13-r1.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild
index f41851e9648d..df76f8cc3b8d 100644
--- a/dev-php/pecl-ssh2/pecl-ssh2-0.13-r1.ebuild
+++ b/dev-php/pecl-ssh2/pecl-ssh2-0.13-r2.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PHP_EXT_NAME="ssh2"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-USE_PHP="php7-0 php5-6"
+USE_PHP="php5-6 php7-0 php7-1"
inherit php-ext-pecl-r3
@@ -18,10 +16,10 @@ LICENSE="PHP-3.01"
SLOT="0"
IUSE=""
KEYWORDS="~amd64 ~x86"
-DEPEND=">=net-libs/libssh2-1.2"
+DEPEND="net-libs/libssh2"
RDEPEND="${DEPEND}"
-PHP_EXT_ECONF_ARGS=""
-PDEPEND="php_targets_php7-0? ( dev-php/pecl-ssh2:7 )"
+PDEPEND="php_targets_php7-0? ( dev-php/pecl-ssh2:7 )
+ php_targets_php7-1? ( dev-php/pecl-ssh2:7 )"
src_prepare(){
if use php_targets_php5-6 ; then