summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-06-11 12:09:07 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-06-11 12:33:58 -0400
commit26ff2830784f8ec2d0ae34ebd2fed92ddb88f10c (patch)
tree6c8df31289376bd65bfbd6059c9c8ba25aaa8ff5 /dev-php/PEAR-Console_CommandLine
parentdev-php/PEAR-Crypt_GPG: add 1.6.9 (diff)
downloadgentoo-26ff2830784f8ec2d0ae34ebd2fed92ddb88f10c.tar.gz
gentoo-26ff2830784f8ec2d0ae34ebd2fed92ddb88f10c.tar.bz2
gentoo-26ff2830784f8ec2d0ae34ebd2fed92ddb88f10c.zip
dev-php/PEAR-Console_CommandLine: add 1.2.6
Closes: https://bugs.gentoo.org/774768 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-Console_CommandLine')
-rw-r--r--dev-php/PEAR-Console_CommandLine/Manifest1
-rw-r--r--dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.6.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-php/PEAR-Console_CommandLine/Manifest b/dev-php/PEAR-Console_CommandLine/Manifest
index 08a0a05aec75..c0ada322b9e5 100644
--- a/dev-php/PEAR-Console_CommandLine/Manifest
+++ b/dev-php/PEAR-Console_CommandLine/Manifest
@@ -1 +1,2 @@
DIST Console_CommandLine-1.2.2.tgz 40705 BLAKE2B 1cf2fd7ffdafe1b6e683d40e24c07bc12c9e41469e42595f40778f0bfef30457b32f80b966835a690724e29216348be0fb3f98a83947459d48f728896a5a056a SHA512 05dbde123d0d4fdbba2a959f4bea3b115e3629060a268d25a3007c2ee5a3530b8ebbd8c7d124a6c9d012cafa19f41690a888943a6c1e2e5ec1b9d83fa821d603
+DIST Console_CommandLine-1.2.6.tgz 36389 BLAKE2B a2ad049324653d9e2dc5b438619dec5caed3cba1703395da0838ec521c08b37bdc693aa79ed87e2cc4e3e2382c7ebcaa340da34716eeb3700c4242cf5c05afdd SHA512 bd3a04915b6cc1dc07d2aad4c5714d7b3ed373c938bc945f0bd71d1686788d2be9cb9a3cdf5021f34a200b361d76a664921334d4e462e011502e37d0a8fbd891
diff --git a/dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.6.ebuild b/dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.6.ebuild
new file mode 100644
index 000000000000..043f5229838d
--- /dev/null
+++ b/dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A full-featured command-line options and arguments parser"
+HOMEPAGE="https://pear.php.net/package/Console_CommandLine"
+SRC_URI="https://github.com/pear/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~sparc ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-Exception"
+
+# Beware, the test suite really needs PEAR-PEAR.
+DEPEND="test? ( ${RDEPEND} dev-php/PEAR-PEAR )"
+
+src_prepare() {
+ # There's one occurrence of @data_dir@ that needs to be replaced
+ # This location just has to agree with where we put the "data"
+ # directory during src_install().
+ default
+ sed -i "s|@data_dir@|${EPREFIX}/usr/share|" \
+ Console/CommandLine/XmlParser.php || die
+
+ # These two fail, but only due to the ordering of the associative
+ # arrays in the expected output. Github issue tracking is disabled
+ # but the current maintainer of the repo has been emailed about it.
+ rm tests/console_commandline_{addargument,addoption}.phpt || die
+}
+
+src_install() {
+ use examples && dodoc -r docs/examples
+
+ insinto "/usr/share/${MY_PN}"
+ doins -r data
+
+ insinto /usr/share/php
+ doins -r Console
+}
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}