summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-22 00:31:36 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-22 02:21:54 +1200
commited4f9573f4b20d05199d5a848f0c32c54e3ed460 (patch)
tree38ae78ff2210c82908f2fad2f2dcbdae988dcb66 /dev-perl
parentdev-perl/HTTP-Exception: Add w/ version=0.40.70 (diff)
downloadgentoo-ed4f9573f4b20d05199d5a848f0c32c54e3ed460.tar.gz
gentoo-ed4f9573f4b20d05199d5a848f0c32c54e3ed460.tar.bz2
gentoo-ed4f9573f4b20d05199d5a848f0c32c54e3ed460.zip
dev-perl/CGI-Application-Dispatch: Add w/ version=3.120.0-r2
- The -r bump is necessary to be an upgrade from ::perl-experimental - Required by: - dev-perl/CGI-Application-Server - via dev-perl/Feed-Find (-r patch) Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/CGI-Application-Dispatch/CGI-Application-Dispatch-3.120.0-r2.ebuild34
-rw-r--r--dev-perl/CGI-Application-Dispatch/Manifest1
-rw-r--r--dev-perl/CGI-Application-Dispatch/metadata.xml14
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-perl/CGI-Application-Dispatch/CGI-Application-Dispatch-3.120.0-r2.ebuild b/dev-perl/CGI-Application-Dispatch/CGI-Application-Dispatch-3.120.0-r2.ebuild
new file mode 100644
index 000000000000..b70bb8229586
--- /dev/null
+++ b/dev-perl/CGI-Application-Dispatch/CGI-Application-Dispatch-3.120.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MARKSTOS
+DIST_VERSION=3.12
+inherit perl-module
+
+DESCRIPTION="Dispatch requests to CGI::Application based objects"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ >=dev-perl/CGI-Application-4.500.0
+ dev-perl/CGI-PSGI
+ >=dev-perl/Exception-Class-1.200.0
+ dev-perl/HTTP-Exception
+ dev-perl/Try-Tiny
+ >=virtual/perl-version-0.820.0
+"
+DEPEND="dev-perl/Module-Build"
+# Todo: add Apache::Test and mod_perl w/
+# USE=minimal, currently can't due to mod_perl
+# breaking w/ ranlib fun
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ >=dev-perl/Plack-0.995.600
+ dev-perl/Test-LongString
+ virtual/perl-Test-Simple
+ )
+"
diff --git a/dev-perl/CGI-Application-Dispatch/Manifest b/dev-perl/CGI-Application-Dispatch/Manifest
new file mode 100644
index 000000000000..2d425a6e7794
--- /dev/null
+++ b/dev-perl/CGI-Application-Dispatch/Manifest
@@ -0,0 +1 @@
+DIST CGI-Application-Dispatch-3.12.tar.gz 38322 BLAKE2B f33b0b8e674e5e2ede95daeb84f1ea3a0f57e479abe98f339cc0545530a03e1a25da13cca0ae09a162ebcc917855c9486ab1f228bcb5e79082608edbf7082bd9 SHA512 b450eb732468677ed86f72da7dda7f18d184bffa57cd59c79dc331a4c4a8d07f7a672abab75963e1c3f57a0f59d068b0f832e2b306d583eb0f878bc43548c37e
diff --git a/dev-perl/CGI-Application-Dispatch/metadata.xml b/dev-perl/CGI-Application-Dispatch/metadata.xml
new file mode 100644
index 000000000000..5bb0da53e2f8
--- /dev/null
+++ b/dev-perl/CGI-Application-Dispatch/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">CGI-Application-Dispatch</remote-id>
+ <remote-id type="cpan-module">CGI::Application::Dispatch</remote-id>
+ <remote-id type="cpan-module">CGI::Application::Dispatch::PSGI</remote-id>
+ <remote-id type="cpan-module">CGI::Application::Dispatch::Regexp</remote-id>
+ </upstream>
+</pkgmetadata>