summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-06-17 01:03:38 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-06-17 01:03:38 +0200
commit3fbc2fc8a2d0aaf822cf711ffe33ee928b3b450a (patch)
treecd8bf6367be9ae7efd762e18e14a26d45c0872a2 /dev-perl
parentdev-perl/Test-SubCalls: Add fix for Perl 5.26 no-dot-in-inc, bug 615696 (diff)
downloadgentoo-3fbc2fc8a2d0aaf822cf711ffe33ee928b3b450a.tar.gz
gentoo-3fbc2fc8a2d0aaf822cf711ffe33ee928b3b450a.tar.bz2
gentoo-3fbc2fc8a2d0aaf822cf711ffe33ee928b3b450a.zip
dev-perl/Test-SubCalls: Fix Perl 5.26 dot-in-inc as recommended by upstream. Bug 615696.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Test-SubCalls/Test-SubCalls-1.90.0-r1.ebuild14
-rw-r--r--dev-perl/Test-SubCalls/files/Test-SubCalls-1.90.0-dot.patch7
2 files changed, 11 insertions, 10 deletions
diff --git a/dev-perl/Test-SubCalls/Test-SubCalls-1.90.0-r1.ebuild b/dev-perl/Test-SubCalls/Test-SubCalls-1.90.0-r1.ebuild
index d0e120168fea..4231a50ee122 100644
--- a/dev-perl/Test-SubCalls/Test-SubCalls-1.90.0-r1.ebuild
+++ b/dev-perl/Test-SubCalls/Test-SubCalls-1.90.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-MODULE_AUTHOR=ADAMK
-MODULE_VERSION=1.09
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.09
inherit perl-module
DESCRIPTION="Track the number of times subs are called"
@@ -17,10 +17,4 @@ DEPEND=">=dev-perl/Hook-LexWrap-0.20
virtual/perl-File-Spec"
RDEPEND="${DEPEND}"
-SRC_TEST="do"
-
-src_prepare() {
- sed -i -e 's/use inc::Module::Install::DSL /use lib q[.]; use inc::Module::Install::DSL /' Makefile.PL ||
- die "Can't patch Makefile.PL for 5.26 dot-in-inc"
- perl-module_src_prepare
-}
+PATCHES=( "${FILESDIR}/${P}"-dot.patch )
diff --git a/dev-perl/Test-SubCalls/files/Test-SubCalls-1.90.0-dot.patch b/dev-perl/Test-SubCalls/files/Test-SubCalls-1.90.0-dot.patch
new file mode 100644
index 000000000000..0be86a6037dd
--- /dev/null
+++ b/dev-perl/Test-SubCalls/files/Test-SubCalls-1.90.0-dot.patch
@@ -0,0 +1,7 @@
+--- a/Makefile.PL 2017-03-31 09:05:12.495038191 -0400
++++ b/Makefile.PL 2017-03-31 09:05:22.634214621 -0400
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install::DSL 0.83;
+
+ all_from lib/Test/SubCalls.pm