summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-26 03:39:58 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-29 21:35:59 +0200
commit80338b99b3ad139121f941e93d73c997b9f22781 (patch)
treef33f689b836704e9912a607775756d3ce0b635a3 /dev-perl/Wx
parentdev-perl/Want: Bump to version 0.290.0 (diff)
downloadgentoo-80338b99b3ad139121f941e93d73c997b9f22781.tar.gz
gentoo-80338b99b3ad139121f941e93d73c997b9f22781.tar.bz2
gentoo-80338b99b3ad139121f941e93d73c997b9f22781.zip
dev-perl/Wx: Bump to version 0.992.800
- EAPI6 - Tests cleaned up slightly - Tests re-enabled as per bug #571470, if tests still hang, please augment perl_rm_files in src_test to work out which test is hanging, and then we can go from there. Upstream: - Fixed memory leak in Wx::Timer Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Wx')
-rw-r--r--dev-perl/Wx/Manifest1
-rw-r--r--dev-perl/Wx/Wx-0.992.800.ebuild44
-rw-r--r--dev-perl/Wx/metadata.xml23
3 files changed, 60 insertions, 8 deletions
diff --git a/dev-perl/Wx/Manifest b/dev-perl/Wx/Manifest
index 5bdc8e1df23d..d9da84ebf2d3 100644
--- a/dev-perl/Wx/Manifest
+++ b/dev-perl/Wx/Manifest
@@ -1,3 +1,4 @@
DIST Wx-0.9902.tar.gz 406639 SHA256 ea4982993de1a188d4bc130d785f10faa0fda4c8521b08b3768915d0ed8b7ebf SHA512 e6d1061319c0232b0f5109f314b88c771960aeb2ce18effd4bf040fd377edd0f9ab94f3359c318b52a40fe73bd8e1a0c9f90d87d5c23690435303e644e5bbfd3 WHIRLPOOL 59f4b30616931d3c89bd61076bbaf69592ec0facb3eb063387d8d34f004b5c42775b5bafe688d2bd5458af9556c023a6149a0e104d7ef34403eccb9c760dc353
DIST Wx-0.9917.tar.gz 485343 SHA256 1356f7830173ad17ad8bd760306ac101c05165613cb87e02d843f20c340c085a SHA512 6b06bfdd7ab883eaf8e6b3aed62ecf9105c2388be353a8c51355695543121350ead2040c51a4cf5a6ebacd1e8096cc76e9c77be0222fbc2c3ce2335028118fc8 WHIRLPOOL c907f852f977adc90b6438321151bd72aaf61b517c4e146e74848325e78bc4c5f8b64d210e4bd78d6ac23d7a51002660f21712b1b43a3e777c545926e10a020f
DIST Wx-0.9927.tar.gz 486022 SHA256 a174bd1b6a5558174697775be0ede2fb8260258d60bb6e116dfe6f56ac1d22bb SHA512 9f81b0c5f8017ca03eeb773555842d3e2b8360b20b071534f9f6501094af0f5371a0b2cfb5cd490b7ee77316ad3005183ff8c16f945393bff2d615e4d8721726 WHIRLPOOL 1210eb83969ab1ab6b89dc8b1aa7d605406276b22dcaf35bdc1a2c9d02ecbb8a1ac88ed15f9852f9e38b959215cd4d55a2747204c37f4a61ebac69b7d7ea8a5b
+DIST Wx-0.9928.tar.gz 501439 SHA256 58e06c094c07817617b1e69fa0501f2cee80cd4700ac7a62c516179f7aa85b42 SHA512 9ddb946e1a6a7f670fcc27ece4227821cfa9b2fcebe078e8452e924a8786fca8c20c53262a5fa2f93ecd6586a82d42af77920ec543817a0552749caca2c552f6 WHIRLPOOL e8d3b68a7cf1ecaaa8134b7108606b3c8f8116908ab3daff1502f0023a469ca608ab5c310405dea68a7afb8baac4bcfae08cc576d96fb1256c9a30d210e1b248
diff --git a/dev-perl/Wx/Wx-0.992.800.ebuild b/dev-perl/Wx/Wx-0.992.800.ebuild
new file mode 100644
index 000000000000..99b7666eb871
--- /dev/null
+++ b/dev-perl/Wx/Wx-0.992.800.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+DIST_AUTHOR=MDOOTSON
+DIST_VERSION=0.9928
+DIST_EXAMPLES=("samples/*")
+inherit wxwidgets virtualx perl-module
+
+DESCRIPTION="Perl bindings for wxGTK"
+HOMEPAGE="http://wxperl.sourceforge.net/ ${HOMEPAGE}"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Alien-wxWidgets-0.670.0
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=virtual/perl-File-Spec-0.820.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.480.0
+ >=virtual/perl-ExtUtils-ParseXS-3.150.0
+ >=dev-perl/ExtUtils-XSpp-0.160.200
+ >=virtual/perl-if-0.30.0
+ test? (
+ >=virtual/perl-Test-Harness-2.260.0
+ >=virtual/perl-Test-Simple-0.430.0
+ )
+"
+
+src_prepare() {
+ need-wxwidgets base-unicode
+ perl-module_src_prepare
+}
+
+src_test() {
+ perl_rm_files t/12_pod.t
+ virtx perl-module_src_test
+}
diff --git a/dev-perl/Wx/metadata.xml b/dev-perl/Wx/metadata.xml
index 950b6a7bf520..83b4e2839b6c 100644
--- a/dev-perl/Wx/metadata.xml
+++ b/dev-perl/Wx/metadata.xml
@@ -25,10 +25,16 @@
<remote-id type="cpan-module">Wx::Calendar</remote-id>
<remote-id type="cpan-module">Wx::CalendarCtrl</remote-id>
<remote-id type="cpan-module">Wx::CalendarEvent</remote-id>
+ <remote-id type="cpan-module">Wx::Client</remote-id>
<remote-id type="cpan-module">Wx::ColourProperty</remote-id>
<remote-id type="cpan-module">Wx::ColourPropertyValue</remote-id>
+ <remote-id type="cpan-module">Wx::Connection</remote-id>
+ <remote-id type="cpan-module">Wx::Connectionbase</remote-id>
<remote-id type="cpan-module">Wx::ContextHelpButton</remote-id>
<remote-id type="cpan-module">Wx::CursorProperty</remote-id>
+ <remote-id type="cpan-module">Wx::DDEClient</remote-id>
+ <remote-id type="cpan-module">Wx::DDEConnection</remote-id>
+ <remote-id type="cpan-module">Wx::DDEServer</remote-id>
<remote-id type="cpan-module">Wx::DND</remote-id>
<remote-id type="cpan-module">Wx::DataObject</remote-id>
<remote-id type="cpan-module">Wx::DataObjectComposite</remote-id>
@@ -66,7 +72,6 @@
<remote-id type="cpan-module">Wx::DropFilesEvent</remote-id>
<remote-id type="cpan-module">Wx::DropSource</remote-id>
<remote-id type="cpan-module">Wx::DropTarget</remote-id>
- <remote-id type="cpan-module">Wx::Droptarget</remote-id>
<remote-id type="cpan-module">Wx::EditEnumProperty</remote-id>
<remote-id type="cpan-module">Wx::EnumProperty</remote-id>
<remote-id type="cpan-module">Wx::Event</remote-id>
@@ -133,6 +138,7 @@
<remote-id type="cpan-module">Wx::HtmlWinTagHandler</remote-id>
<remote-id type="cpan-module">Wx::HtmlWindow</remote-id>
<remote-id type="cpan-module">Wx::HtmlWordCell</remote-id>
+ <remote-id type="cpan-module">Wx::IPC</remote-id>
<remote-id type="cpan-module">Wx::IPV4address</remote-id>
<remote-id type="cpan-module">Wx::IPV6address</remote-id>
<remote-id type="cpan-module">Wx::IPaddress</remote-id>
@@ -147,9 +153,6 @@
<remote-id type="cpan-module">Wx::MDIChildFrame</remote-id>
<remote-id type="cpan-module">Wx::MDIClientWindow</remote-id>
<remote-id type="cpan-module">Wx::MDIParentFrame</remote-id>
- <remote-id type="cpan-module">Wx::Media</remote-id>
- <remote-id type="cpan-module">Wx::MediaCtrl</remote-id>
- <remote-id type="cpan-module">Wx::MediaEvent</remote-id>
<remote-id type="cpan-module">Wx::Menu</remote-id>
<remote-id type="cpan-module">Wx::Mini</remote-id>
<remote-id type="cpan-module">Wx::MultiChoiceProperty</remote-id>
@@ -184,7 +187,9 @@
<remote-id type="cpan-module">Wx::Perl::TextValidator</remote-id>
<remote-id type="cpan-module">Wx::PerlTest</remote-id>
<remote-id type="cpan-module">Wx::PlArtProvider</remote-id>
+ <remote-id type="cpan-module">Wx::PlClient</remote-id>
<remote-id type="cpan-module">Wx::PlCommand</remote-id>
+ <remote-id type="cpan-module">Wx::PlConnection</remote-id>
<remote-id type="cpan-module">Wx::PlDataObjectSimple</remote-id>
<remote-id type="cpan-module">Wx::PlDataViewIndexListModel</remote-id>
<remote-id type="cpan-module">Wx::PlDropTarget</remote-id>
@@ -199,6 +204,7 @@
<remote-id type="cpan-module">Wx::PlHtmlWinTagHandler</remote-id>
<remote-id type="cpan-module">Wx::PlPreviewControlBar</remote-id>
<remote-id type="cpan-module">Wx::PlPreviewFrame</remote-id>
+ <remote-id type="cpan-module">Wx::PlServer</remote-id>
<remote-id type="cpan-module">Wx::PlThreadEvent</remote-id>
<remote-id type="cpan-module">Wx::PlXmlResourceHandler</remote-id>
<remote-id type="cpan-module">Wx::PliXmlSubclassFactory</remote-id>
@@ -249,6 +255,7 @@
<remote-id type="cpan-module">Wx::RichTextStyleOrganiserDialog</remote-id>
<remote-id type="cpan-module">Wx::RichTextXMLHandler</remote-id>
<remote-id type="cpan-module">Wx::STC</remote-id>
+ <remote-id type="cpan-module">Wx::Server</remote-id>
<remote-id type="cpan-module">Wx::SimpleApp</remote-id>
<remote-id type="cpan-module">Wx::SimpleHelpProvider</remote-id>
<remote-id type="cpan-module">Wx::SimpleHtmlListBox</remote-id>
@@ -262,6 +269,9 @@
<remote-id type="cpan-module">Wx::StyledTextEvent</remote-id>
<remote-id type="cpan-module">Wx::SymbolPickerDialog</remote-id>
<remote-id type="cpan-module">Wx::SystemColourProperty</remote-id>
+ <remote-id type="cpan-module">Wx::TCPClient</remote-id>
+ <remote-id type="cpan-module">Wx::TCPConnection</remote-id>
+ <remote-id type="cpan-module">Wx::TCPServer</remote-id>
<remote-id type="cpan-module">Wx::TextAttrEx</remote-id>
<remote-id type="cpan-module">Wx::TextDataObject</remote-id>
<remote-id type="cpan-module">Wx::TextDropTarget</remote-id>
@@ -273,13 +283,10 @@
<remote-id type="cpan-module">Wx::UNIXaddress</remote-id>
<remote-id type="cpan-module">Wx::URLDataObject</remote-id>
<remote-id type="cpan-module">Wx::View</remote-id>
- <remote-id type="cpan-module">Wx::WebView</remote-id>
- <remote-id type="cpan-module">Wx::WebViewArchiveHandler</remote-id>
- <remote-id type="cpan-module">Wx::WebViewEvent</remote-id>
- <remote-id type="cpan-module">Wx::WebViewHandler</remote-id>
<remote-id type="cpan-module">Wx::WinHelpController</remote-id>
<remote-id type="cpan-module">Wx::WindowsPrintPreview</remote-id>
<remote-id type="cpan-module">Wx::WindowsPrinter</remote-id>
+ <remote-id type="cpan-module">Wx::Wx_Exp</remote-id>
<remote-id type="cpan-module">Wx::XRC</remote-id>
<remote-id type="cpan-module">Wx::XSP::Enum</remote-id>
<remote-id type="cpan-module">Wx::XSP::Event</remote-id>