summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-05-09 07:20:21 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-05-21 02:11:08 +0200
commitcb9ac2c84be6867c3cf98ed764b3e58034f24bbb (patch)
tree983e58baab3127750f67ceaa618b54af5e298fcb /dev-perl/WWW-Pastebin-PastebinCom-Create/WWW-Pastebin-PastebinCom-Create-1.3.0-r1.ebuild
parentdev-perl/AnyEvent-CacheDNS: Disable tests without explict network grants. (diff)
downloadgentoo-cb9ac2c84be6867c3cf98ed764b3e58034f24bbb.tar.gz
gentoo-cb9ac2c84be6867c3cf98ed764b3e58034f24bbb.tar.bz2
gentoo-cb9ac2c84be6867c3cf98ed764b3e58034f24bbb.zip
dev-perl/WWW-Pastebin-PastebinCom-Create: Exclude network tests.
-r1 bump required because to detect network options, we need EAPI6-only perl-module.eclass features. But in-place EAPI6 changes are suspected to be dangerous. This module is not so complex, so an -r1 bump should be better than worrying about random breakage. Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/WWW-Pastebin-PastebinCom-Create/WWW-Pastebin-PastebinCom-Create-1.3.0-r1.ebuild')
-rw-r--r--dev-perl/WWW-Pastebin-PastebinCom-Create/WWW-Pastebin-PastebinCom-Create-1.3.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/WWW-Pastebin-PastebinCom-Create/WWW-Pastebin-PastebinCom-Create-1.3.0-r1.ebuild b/dev-perl/WWW-Pastebin-PastebinCom-Create/WWW-Pastebin-PastebinCom-Create-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..8dff92c9be33
--- /dev/null
+++ b/dev-perl/WWW-Pastebin-PastebinCom-Create/WWW-Pastebin-PastebinCom-Create-1.3.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=ZOFFIX
+DIST_VERSION=1.003
+inherit perl-module
+
+DESCRIPTION="Paste on www.pastebin.com without API keys"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Moo-1.4.1
+ >=dev-perl/WWW-Mechanize-1.730.0
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ local my_test_control=${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}
+ if ! has network ${my_test_control} ; then
+ einfo "Supressing Network Test without DIST_TEST_OVERRIDE =~ network"
+ perl_rm_files t/01-paste.t
+ fi
+ perl-module_src_test
+}