summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-14 08:20:02 +0100
committerSam James <sam@gentoo.org>2023-08-14 08:54:45 +0100
commit8cc37414f50b8b83524aa6ab63d93305ed1d4fee (patch)
treebba13049cd8cc862dadca20fcb8f503a6291fe58 /dev-perl/Data-Printer/Data-Printer-1.1.1.ebuild
parentdev-perl/Business-ISBN-Data: add 20230811.1.0 (diff)
downloadgentoo-8cc37414f50b8b83524aa6ab63d93305ed1d4fee.tar.gz
gentoo-8cc37414f50b8b83524aa6ab63d93305ed1d4fee.tar.bz2
gentoo-8cc37414f50b8b83524aa6ab63d93305ed1d4fee.zip
dev-perl/Data-Printer: add 1.1.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Data-Printer/Data-Printer-1.1.1.ebuild')
-rw-r--r--dev-perl/Data-Printer/Data-Printer-1.1.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Data-Printer/Data-Printer-1.1.1.ebuild b/dev-perl/Data-Printer/Data-Printer-1.1.1.ebuild
new file mode 100644
index 000000000000..1e2208693115
--- /dev/null
+++ b/dev-perl/Data-Printer/Data-Printer-1.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=GARU
+DIST_VERSION=1.001001
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Colored and full-featured pretty print of Perl data structures and objects"
+
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Temp
+ virtual/perl-Test-Simple
+ )
+"