summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-06 01:38:12 +0100
committerSam James <sam@gentoo.org>2021-10-06 02:00:54 +0100
commite387c933eb9edb5f4819034a3a34864c3ce0ab5e (patch)
treed290fd8ed499ffa2130c9a9e0325a51cbbd11202 /dev-ml/re/re-1.10.3.ebuild
parentdev-ml/uucp: add 14.0.0 (diff)
downloadgentoo-e387c933eb9edb5f4819034a3a34864c3ce0ab5e.tar.gz
gentoo-e387c933eb9edb5f4819034a3a34864c3ce0ab5e.tar.bz2
gentoo-e387c933eb9edb5f4819034a3a34864c3ce0ab5e.zip
dev-ml/re: add 1.10.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/re/re-1.10.3.ebuild')
-rw-r--r--dev-ml/re/re-1.10.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/re/re-1.10.3.ebuild b/dev-ml/re/re-1.10.3.ebuild
new file mode 100644
index 000000000000..9dc727449c23
--- /dev/null
+++ b/dev-ml/re/re-1.10.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Regular expression library for OCaml"
+HOMEPAGE="https://github.com/ocaml/ocaml-re"
+SRC_URI="https://github.com/ocaml/ocaml-re/archive/${PV}.tar.gz -> ocaml-${P}.tar.gz"
+S="${WORKDIR}/ocaml-${P}"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="!dev-ml/ocaml-re
+ dev-ml/seq:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 )"
+
+PATCHES=( "${FILESDIR}/ounit2.patch" )