summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-07-13 18:53:06 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-07-13 18:53:06 +0200
commitb33f613fe199bc5712a218e23890ea74588a0b44 (patch)
tree898aee54fc16ef109e739e15ce8958f5b8b8c20b /dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild
parentgames-puzzle/neverball: EAPI 6->7, fix prefix and AbsoluteSymlink (diff)
downloadgentoo-b33f613fe199bc5712a218e23890ea74588a0b44.tar.gz
gentoo-b33f613fe199bc5712a218e23890ea74588a0b44.tar.bz2
gentoo-b33f613fe199bc5712a218e23890ea74588a0b44.zip
dev-ml/ppx_expect: bump to 0.14.1
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild')
-rw-r--r--dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild b/dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild
new file mode 100644
index 000000000000..9d7682d713fc
--- /dev/null
+++ b/dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Cram like framework for OCaml"
+HOMEPAGE="https://github.com/janestreet/ppx_expect"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ >=dev-ml/ppx_here-0.14.0:=
+ >=dev-ml/ppx_inline_test-0.14.1:=
+ >=dev-ml/stdio-0.14.0:=
+ >=dev-ml/ppxlib-0.18.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+ dev-ml/re:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? (
+ dev-ml/ppx_jane
+ )"
+# https://bugs.gentoo.org/749291#c2
+RESTRICT=test