summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-01-14 20:48:10 -0500
committerMike Gilbert <floppym@gentoo.org>2023-01-14 20:54:16 -0500
commit9c414b3f9c6e171687b801cc3daa7c6af698491c (patch)
tree32e480f2bf1205766c7f096f1f9ba43e27e8bbb5 /dev-libs
parentsci-geosciences/gpsd: add 3.25 (diff)
downloadgentoo-9c414b3f9c6e171687b801cc3daa7c6af698491c.tar.gz
gentoo-9c414b3f9c6e171687b801cc3daa7c6af698491c.tar.bz2
gentoo-9c414b3f9c6e171687b801cc3daa7c6af698491c.zip
dev-libs/openssl: tweak config/Configure for 1.1.1 branch
If gentoo.config succeeds, call "perl Configure ...". This uses perl from PATH to avoid issue on prefix, and bypasses the funky config shell script. If gentoo.config fails, call "sh config -v ...". This uses sh from PATH to avoid any issues on prefix, and produces verbose output for the build log. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/openssl-1.1.1s-r1.ebuild17
1 files changed, 6 insertions, 11 deletions
diff --git a/dev-libs/openssl/openssl-1.1.1s-r1.ebuild b/dev-libs/openssl/openssl-1.1.1s-r1.ebuild
index e2f32f1b8861..910d8fcfbda4 100644
--- a/dev-libs/openssl/openssl-1.1.1s-r1.ebuild
+++ b/dev-libs/openssl/openssl-1.1.1s-r1.ebuild
@@ -132,11 +132,6 @@ src_prepare() {
append-flags $(test-flags-CC -Wa,--noexecstack)
- # Prefixify Configure shebang (bug #141906)
- sed \
- -e "1s,/usr/bin/env,${BROOT}&," \
- -i Configure || die
-
# Remove test target when FEATURES=test isn't set
if ! use test ; then
sed \
@@ -160,12 +155,12 @@ src_prepare() {
local sslout=$(./gentoo.config)
einfo "Using configuration: ${sslout:-(openssl knows best)}"
- local config="Configure"
- [[ -z ${sslout} ]] && config="config"
+ local config="perl Configure"
+ [[ -z ${sslout} ]] && config="sh config -v"
# The config script does stupid stuff to prompt the user. Kill it.
sed -i '/stty -icanon min 0 time 50; read waste/d' config || die
- edo ./${config} ${sslout} --test-sanity || die "I AM NOT SANE"
+ edo ${config} ${sslout} --test-sanity
multilib_copy_sources
}
@@ -198,8 +193,8 @@ multilib_src_configure() {
local sslout=$(./gentoo.config)
einfo "Use configuration ${sslout:-(openssl knows best)}"
- local config="Configure"
- [[ -z ${sslout} ]] && config="config"
+ local config="perl Configure"
+ [[ -z ${sslout} ]] && config="sh config -v"
# "disable-deprecated" option breaks too many consumers.
# Don't set it without thorough revdeps testing.
@@ -237,7 +232,7 @@ multilib_src_configure() {
threads
)
- CFLAGS= LDFLAGS= edo ./${config} "${myeconfargs[@]}"
+ CFLAGS= LDFLAGS= edo ${config} "${myeconfargs[@]}"
# Clean out hardcoded flags that openssl uses
local DEFAULT_CFLAGS=$(grep ^CFLAGS= Makefile | LC_ALL=C sed \