summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-10-18 19:01:53 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-10-18 19:05:08 -0400
commit36b2a924c1c25ebc6402cbad377799b764939d9c (patch)
treea6c9460746746eef53af17ff67234a589c7a64bc /dev-libs/xapian-bindings
parentdev-libs/xapian: version bump to 1.4.5 (diff)
downloadgentoo-36b2a924c1c25ebc6402cbad377799b764939d9c.tar.gz
gentoo-36b2a924c1c25ebc6402cbad377799b764939d9c.tar.bz2
gentoo-36b2a924c1c25ebc6402cbad377799b764939d9c.zip
dev-libs/xapian-bindings: version bump to 1.4.5
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-libs/xapian-bindings')
-rw-r--r--dev-libs/xapian-bindings/Manifest1
-rw-r--r--dev-libs/xapian-bindings/xapian-bindings-1.4.5.ebuild160
2 files changed, 161 insertions, 0 deletions
diff --git a/dev-libs/xapian-bindings/Manifest b/dev-libs/xapian-bindings/Manifest
index 3aa7e42c30e3..b3cc9eea8557 100644
--- a/dev-libs/xapian-bindings/Manifest
+++ b/dev-libs/xapian-bindings/Manifest
@@ -2,3 +2,4 @@ DIST xapian-bindings-1.2.22.tar.xz 844040 SHA256 b15ca7984980a1d2aedd3378648ef5f
DIST xapian-bindings-1.2.24.tar.xz 886148 SHA256 0c2a0df0a4616e2bd8e578d372c9bb4684780573abebbd1ac515502177229965 SHA512 aaedac02ec9fb192ef8b45b07bef5584bc60aff7068c2e3fa0008430ed8296a653780cad04176431d81fe014802df333a3090469dce63204923eead15e6bbaef WHIRLPOOL 996b960727a79dbe669ae8139863c3896c6efdbe781177098d00960982b86a43739433c69db32e62b6660dd4751736d859f5d950d26d6b635c310c35d75a8a0f
DIST xapian-bindings-1.2.25.tar.xz 1711860 SHA256 5f07425d6c5fc540fab965cd011bb043e3ee0df7da03a8814d6fc20dc5e9dd0f SHA512 5d27b2ae2722409ea99a1b9e6bf3f5c61ed9195b67121c090f1533340d3b11c546014985d0989a0725b60a07b392b9705bce054495f423bd3a7c99835aa336c7 WHIRLPOOL aa5c5c310bee6d10f75bb0586386982ec9c32af0b9fbffde8f8c12c37d4a306c66bea69f6dd5502aa6ca93d9d288720fef0d8f7ab6bcea235803c2e3c5b3e57e
DIST xapian-bindings-1.4.4.tar.xz 1117140 SHA256 3b323eac41c42750b7dacc9319b1477a7c1b552c95f590127643dee3b44d8a39 SHA512 006e771b3ea654130b4f76f1a1caee576fd5a3fa6317ca44f1e5483671e8c83073ecbde4f3fc7f84c75590eec53acb59701af4cf9bcd72355ed9d53924492b53 WHIRLPOOL 6932654e8fb4feea2de6db9f58273ab1fd253e0a90992377224c94a671979e102992052396fc319a5a3a8b3122d6a12d43a4bcd73e81e9dfc2b1a3b04838beae
+DIST xapian-bindings-1.4.5.tar.xz 1118884 SHA256 647886730a71bcc0e9f666fcd702b7141d4e9a82e1085e44eb4470624e1a9d33 SHA512 e39ece495e25077990db3d06554306567c52c6f45ad55a65005cb97e18086ee18947e41d0d612157b891b61e015881385bcb082a03aa0c6452565e90d09e8275 WHIRLPOOL d634e91cd815dc963acec0259d26e4ee96acf28d234bda639a6f927e2165f95a389e7c5f6cb5fe3aa17b70d0838fa3de9a967a26d027268e4d98d67aa0fd580b
diff --git a/dev-libs/xapian-bindings/xapian-bindings-1.4.5.ebuild b/dev-libs/xapian-bindings/xapian-bindings-1.4.5.ebuild
new file mode 100644
index 000000000000..2a25212d28da
--- /dev/null
+++ b/dev-libs/xapian-bindings/xapian-bindings-1.4.5.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE="threads(+)"
+
+USE_PHP="php5-6"
+
+PHP_EXT_NAME="xapian"
+PHP_EXT_INI="yes"
+PHP_EXT_OPTIONAL_USE="php"
+
+inherit distutils-r1 libtool java-pkg-opt-2 mono-env php-ext-source-r3 toolchain-funcs
+
+DESCRIPTION="SWIG and JNI bindings for Xapian"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="java lua mono perl php python ruby tcl"
+REQUIRED_USE="|| ( java lua mono perl php python ruby tcl )"
+
+COMMONDEPEND="dev-libs/xapian:0/30
+ lua? ( dev-lang/lua:= )
+ perl? ( dev-lang/perl:= )
+ python? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+ ruby? ( dev-lang/ruby:= )
+ tcl? ( dev-lang/tcl:= )
+ mono? ( dev-lang/mono )"
+DEPEND="${COMMONDEPEND}
+ virtual/pkgconfig
+ java? ( >=virtual/jdk-1.6 )"
+RDEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jre-1.6 )"
+
+pkg_setup() {
+ use mono && mono-env_pkg_setup
+ use java && java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ use java && java-pkg-opt-2_src_prepare
+
+ # http://trac.xapian.org/ticket/702
+ export XAPIAN_CONFIG="/usr/bin/xapian-config"
+
+ # Accept ruby 2.0 - patch configure directly to avoid autoreconf
+ epatch "${FILESDIR}"/${PN}-1.3.6-allow-ruby-2.0.patch
+
+ if use python; then
+ python_copy_sources
+ fi
+
+ eapply_user
+}
+
+src_configure() {
+ local conf=(
+ --disable-documentation
+ --without-csharp
+ --without-python
+ --without-python3
+ )
+
+ if use java; then
+ export CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)"
+ conf+=( --with-java )
+ fi
+
+ if use perl; then
+ export PERL_ARCH="$(perl -MConfig -e 'print $Config{installvendorarch}')"
+ export PERL_LIB="$(perl -MConfig -e 'print $Config{installvendorlib}')"
+ conf+=( --with-perl )
+ fi
+
+ if use lua; then
+ export LUA_LIB="$($(tc-getPKG_CONFIG) --variable=INSTALL_CMOD lua)"
+ conf+=( --with-lua )
+ fi
+
+ if use php; then
+ if has_version "=dev-lang/php-7*"; then
+ conf+=( --with-php7 )
+ else
+ conf+=( --with-php )
+ fi
+ fi
+
+ use ruby && conf+=( --with-ruby )
+ use tcl && conf+=( --with-tcl )
+ use mono && conf+=( --with-csharp )
+
+ econf ${conf[@]}
+
+ python_configure() {
+ local myconf=(
+ --disable-documentation
+ --without-java
+ --without-lua
+ --without-csharp
+ --without-perl
+ --without-php
+ --without-ruby
+ --without-tcl
+ )
+ if python_is_python3; then
+ myconf+=( --with-python3 )
+ else
+ myconf+=( --with-python )
+ fi
+
+ # Avoid sandbox failures when compiling modules
+ addpredict "$(python_get_sitedir)"
+
+ econf "${myconf[@]}"
+ }
+
+ if use python; then
+ python_foreach_impl run_in_build_dir python_configure
+ fi
+}
+
+src_compile() {
+ default
+ if use python; then
+ unset PYTHONDONTWRITEBYTECODE
+ python_foreach_impl run_in_build_dir emake
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use java; then
+ java-pkg_dojar java/built/xapian_jni.jar
+ # TODO: make the build system not install this...
+ java-pkg_doso java/.libs/libxapian_jni.so
+ rm -rf "${D}var" || die "could not remove java cruft!"
+ fi
+
+ use php && php-ext-source-r3_createinifiles
+
+ if use python; then
+ python_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
+ fi
+
+ # For some USE combinations this directory is not created
+ if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
+ mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}" || die
+ fi
+
+ dodoc AUTHORS HACKING NEWS TODO README
+}