summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-02-03 10:52:54 -0800
committerIonen Wolkens <ionen@gentoo.org>2023-02-03 16:48:27 -0500
commit32cc47fd3f546e2ab9c3ed86c4bdfde94eb06d44 (patch)
treecfef59a63b9168949e45e7bfb840b7b7dfe54aa8 /dev-libs/trio
parentkde-apps/gwenview: drop 22.08.3-r1 (diff)
downloadgentoo-32cc47fd3f546e2ab9c3ed86c4bdfde94eb06d44.tar.gz
gentoo-32cc47fd3f546e2ab9c3ed86c4bdfde94eb06d44.tar.bz2
gentoo-32cc47fd3f546e2ab9c3ed86c4bdfde94eb06d44.zip
dev-libs/trio: Add 1.17.1
Closes: https://github.com/gentoo/gentoo/pull/29415 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-libs/trio')
-rw-r--r--dev-libs/trio/Manifest1
-rw-r--r--dev-libs/trio/trio-1.17.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/trio/Manifest b/dev-libs/trio/Manifest
index cecd5482f771..13860a36a3c4 100644
--- a/dev-libs/trio/Manifest
+++ b/dev-libs/trio/Manifest
@@ -1 +1,2 @@
+DIST trio-1.17.1.tar.gz 466909 BLAKE2B 1403c2534623b536de519cd428ac75480ecc0fcb9fbba693e329a923471947f068cae1e1fd453d10863255369e830ef5d8a75475d95f0f903e66936a9fa48e2b SHA512 574e360d88be838d13d7df5259c68809187a578d8d04981812ff768d3ab80215baf5595952994ec9fabbe3a6ce71512a7cd16d6a29b4f91dcd1b6f2ebcd3ed98
DIST trio-1.17.tar.gz 452237 BLAKE2B 77ff673cc103b07b1424720d28c49d2e33a1402a98d8d21124fabb0cafd3498a99976d808cbbc5a90e1b3a063c6af68c3daf94768d533e4a762b730a253fa012 SHA512 19f4732b32c6a3754677d5766399fa70083c6a78c0d04b1dfa10a578b21405ba3e3d3af6543e4811f5fd305ec2727781a1b0f2888e59c574ca735f8406da7954
diff --git a/dev-libs/trio/trio-1.17.1.ebuild b/dev-libs/trio/trio-1.17.1.ebuild
new file mode 100644
index 000000000000..b95d89d446c0
--- /dev/null
+++ b/dev-libs/trio/trio-1.17.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="doxygen"
+DOCS_DIR="doc"
+
+inherit autotools docs
+
+DESCRIPTION="Portable string functions, focus on the *printf() and *scanf() clones"
+HOMEPAGE="https://daniel.haxx.se/projects/trio/"
+SRC_URI="https://github.com/orbea/trio/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="trio"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}