summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-05-25 10:26:31 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-05-25 10:26:31 -0700
commite974a3b00ac8320a43b3915139972704ca14558c (patch)
treefac13cf05ee53e779303c620b07ac5061f03148d /dev-libs/simdjson
parentdev-libs/simdjson: add 2.0.0 (diff)
downloadgentoo-e974a3b00ac8320a43b3915139972704ca14558c.tar.gz
gentoo-e974a3b00ac8320a43b3915139972704ca14558c.tar.bz2
gentoo-e974a3b00ac8320a43b3915139972704ca14558c.zip
dev-libs/simdjson: drop 0.9.7
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-libs/simdjson')
-rw-r--r--dev-libs/simdjson/files/simdjson-0.8.0-dont-bundle-cxxopts.patch40
-rw-r--r--dev-libs/simdjson/simdjson-0.9.7.ebuild67
2 files changed, 0 insertions, 107 deletions
diff --git a/dev-libs/simdjson/files/simdjson-0.8.0-dont-bundle-cxxopts.patch b/dev-libs/simdjson/files/simdjson-0.8.0-dont-bundle-cxxopts.patch
deleted file mode 100644
index 6a76cf83ed98..000000000000
--- a/dev-libs/simdjson/files/simdjson-0.8.0-dont-bundle-cxxopts.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/dependencies/CMakeLists.txt b/dependencies/CMakeLists.txt
-index 2c41169f..2f5d4436 100644
---- a/dependencies/CMakeLists.txt
-+++ b/dependencies/CMakeLists.txt
-@@ -129,15 +129,3 @@ endfunction()
- if(SIMDJSON_COMPETITION)
- competition_scope_()
- endif()
--
--cmake_dependent_option(SIMDJSON_CXXOPTS "Download cxxopts (necessary for tools)" ON
-- SIMDJSON_ALLOW_DOWNLOADS OFF)
--
--if(SIMDJSON_CXXOPTS)
-- set_off(CXXOPTS_BUILD_EXAMPLES)
-- set_off(CXXOPTS_BUILD_TESTS)
-- set_off(CXXOPTS_ENABLE_INSTALL)
--
-- import_dependency(cxxopts jarro2783/cxxopts 794c975)
-- add_dependency(cxxopts)
--endif()
-diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
-index f1a82be7..b1b7b1a0 100644
---- a/tools/CMakeLists.txt
-+++ b/tools/CMakeLists.txt
-@@ -1,10 +1,8 @@
--if(TARGET cxxopts) # we only build the tools if cxxopts is available
- message(STATUS "We have cxxopts as a dependency and we are buiding the tools (e.g., json2json).")
-- link_libraries(simdjson simdjson-internal-flags simdjson-windows-headers cxxopts)
-+ link_libraries(simdjson simdjson-internal-flags simdjson-windows-headers)
- add_executable(json2json json2json.cpp)
- add_executable(jsonstats jsonstats.cpp)
-- add_executable(jsonpointer jsonpointer.cpp)
-+ add_executable(simdjsonpointer jsonpointer.cpp)
- add_executable(minify minify.cpp)
--else()
-- message(STATUS "We are missing cxxopts as a dependency so the tools (e.g., json2json) are omitted.")
--endif()
-\ No newline at end of file
-+ install(TARGETS json2json jsonstats simdjsonpointer minify DESTINATION bin)
-+
diff --git a/dev-libs/simdjson/simdjson-0.9.7.ebuild b/dev-libs/simdjson/simdjson-0.9.7.ebuild
deleted file mode 100644
index 9ce02457aecb..000000000000
--- a/dev-libs/simdjson/simdjson-0.9.7.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="SIMD accelerated C++ JSON library"
-HOMEPAGE="
- https://simdjson.org/
- https://github.com/simdjson/simdjson
-"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 Boost-1.0 BSD MIT"
-SLOT="0/8"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="test tools"
-
-BDEPEND="
- sys-apps/file
- sys-apps/grep
-"
-DEPEND="
- tools? ( dev-libs/cxxopts:= )
-"
-
-REQUIRED_USE="test? ( tools )"
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}/simdjson-0.8.0-dont-bundle-cxxopts.patch"
- "${FILESDIR}/simdjson-0.9.0-tests.patch"
-)
-
-DOCS=(
- AUTHORS
- CONTRIBUTING.md
- CONTRIBUTORS
- HACKING.md
- README.md
-)
-
-src_prepare() {
- sed -e 's:-Werror ::' -i cmake/simdjson-flags.cmake || die
- cmake_src_prepare
-}
-
-src_configure() {
- local -a mycmakeargs=(
- -DSIMDJSON_ENABLE_THREADS=ON
- )
-
- if use tools; then
- mycmakeargs+=(
- -DSIMDJSON_JUST_LIBRARY=OFF
- -DSIMDJSON_GOOGLE_BENCHMARKS=OFF
- -DSIMDJSON_COMPETITION=OFF
- )
- else
- mycmakeargs+=(
- -DSIMDJSON_JUST_LIBRARY=ON
- )
- fi
-
- cmake_src_configure
-}