summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-12-03 11:24:47 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-12-03 11:24:47 +0100
commit279fd476f3f705c745991e7f25161ccba5983453 (patch)
tree6757526002949fb6fcf314a51b302e311a1481c5 /dev-libs/libxmlb
parentmedia-libs/freetype: Removed old (diff)
downloadgentoo-279fd476f3f705c745991e7f25161ccba5983453.tar.gz
gentoo-279fd476f3f705c745991e7f25161ccba5983453.tar.bz2
gentoo-279fd476f3f705c745991e7f25161ccba5983453.zip
dev-libs/libxmlb: Bump to version 0.3.5
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libxmlb')
-rw-r--r--dev-libs/libxmlb/Manifest1
-rw-r--r--dev-libs/libxmlb/libxmlb-0.3.5.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/libxmlb/Manifest b/dev-libs/libxmlb/Manifest
index 48de0da3228e..8024fdd15636 100644
--- a/dev-libs/libxmlb/Manifest
+++ b/dev-libs/libxmlb/Manifest
@@ -1,3 +1,4 @@
DIST libxmlb-0.1.15.tar.gz 92923 BLAKE2B 97b6af812397dd279e7e3c038627fcf8228cbfa5c3af91ceeb5361e32d37d357eda6a193f627a5f4442426fb08abca1ff11684fe199d9d3a4add72ca4f3f5d08 SHA512 58268b3a690af36c0923afdee3ae58e88bf778eebbc6a439be1bc85ed985efdc20cd7006c976586f7be87310dc091d67dddd370f4bbec58379fc4e7349bfa3d8
DIST libxmlb-0.3.3.tar.gz 116107 BLAKE2B 604228a997618b0a3fc25a652f30c1761bc95649246310354c8ca76b6b189799ba8fa38a21244e354d42d6c0f1fd1640e71ccc7ff48429d3425ae43787cf4648 SHA512 4d06e7a7d4bf2e7d36713134b95a6d78e79f014e4b0b511ec9b11086e7287f9f5a42496c4bce35ecae68de1333d7e14b9d041b71c9a081267452178dd2405e16
DIST libxmlb-0.3.4.tar.gz 118304 BLAKE2B e66d6ca72b2e2b568a2775ee44f4eba0c620b50515bb809ab585f488811e5760a61a79a77535c4f3e5ade029687443b4c780abb5eaa29cc044610e2bfe33eb87 SHA512 91ea55fc35e71a6e8c4ec2a07d19d6da27d3a40ac3958285bb15ad6b05a12d944d15f1987d5e8557c8ec1c28b753c1b267670a8e73790e0003ef4d990d617e75
+DIST libxmlb-0.3.5.tar.gz 118335 BLAKE2B bc644ec810d8cfc8db4da5fd9eef0f97eb02efc4d634bb414e0404984ca7fc35be04dd2041dc4661d63515789a65217ae5ba60e8eb8dfc2d117beca73a69cf43 SHA512 2da4fbb0942a5b42c81bdf49926822b75b5a4b497a7f1c0c704b8ff4c249adeb85d22568a28b68b57a66e0019c13e129fd14d517ad49c7dbead4cd39ee790be3
diff --git a/dev-libs/libxmlb/libxmlb-0.3.5.ebuild b/dev-libs/libxmlb/libxmlb-0.3.5.ebuild
new file mode 100644
index 000000000000..84e2880a46ac
--- /dev/null
+++ b/dev-libs/libxmlb/libxmlb-0.3.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="Library to help create and query binary XML blobs"
+HOMEPAGE="https://github.com/hughsie/libxmlb"
+SRC_URI="https://github.com/hughsie/libxmlb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1+"
+SLOT="0/2" # libxmlb.so version
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doc introspection stemmer test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-arch/xz-utils
+ dev-libs/glib:2
+ sys-apps/util-linux
+ stemmer? ( dev-libs/snowball-stemmer:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection )
+"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/meson-0.47.0
+ virtual/pkgconfig
+ introspection? (
+ $(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
+ )
+"
+
+python_check_deps() {
+ has_version -b "dev-python/setuptools[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc gtkdoc)
+ $(meson_use introspection)
+ $(meson_use stemmer)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}