summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-04-17 20:43:25 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-06-15 00:48:28 +0300
commita3abd1f7ecd68d6c6864b7ba08011912d1b06d95 (patch)
tree22d78291b559d60ca4a5ee27822721abce7c33f8 /dev-libs/libqtxdg
parentdev-util/lxqt-build-tools: add 2.0.0 (diff)
downloadgentoo-a3abd1f7ecd68d6c6864b7ba08011912d1b06d95.tar.gz
gentoo-a3abd1f7ecd68d6c6864b7ba08011912d1b06d95.tar.bz2
gentoo-a3abd1f7ecd68d6c6864b7ba08011912d1b06d95.zip
dev-libs/libqtxdg: add 4.0.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'dev-libs/libqtxdg')
-rw-r--r--dev-libs/libqtxdg/Manifest1
-rw-r--r--dev-libs/libqtxdg/libqtxdg-4.0.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/libqtxdg/Manifest b/dev-libs/libqtxdg/Manifest
index f1f0c4a1822b..83eb94bc78da 100644
--- a/dev-libs/libqtxdg/Manifest
+++ b/dev-libs/libqtxdg/Manifest
@@ -1,2 +1,3 @@
DIST libqtxdg-3.11.0.tar.xz 71688 BLAKE2B df5f9ebe6d964a23c89402419e4b6e27812a25d96d065e64c05348fe833e2c27c06e11260c8c58999b232eaf154404549100b81325e02ec7c10eaa40d68ff4cd SHA512 494140fa35e184c128c851f06501b5c62324a796d3f61ed47b750dbdffff756c1a42240d4458797e2f2f01c9b06b997f0fbfc76fe7f99866f7cad084ac1342f7
DIST libqtxdg-3.12.0.tar.xz 71684 BLAKE2B 909fe97ccd8815d9d923d440abef9f0e9cf28fa8e18220f6998e69ff17a1bbb28b37c734758c01cb0a9537464fb0dd2f38b1f61640fd8468c30f8aac57e62106 SHA512 9db46b0dddb027a24e1c19a2e3679014735cc246f15d32bc5fb9e778cd7d8fb57c9b105f819091308002f0a2eff8269920ecc0d7bd5ce8a01fbaf0b37e61a76e
+DIST libqtxdg-4.0.0.tar.xz 71508 BLAKE2B 823bfaba4ea1beb88b064d4935e7c660569b9215aa9f40b7ad6e3ffab965259467d968cd6b5f0c42c2912478d2766d52d52f0296d9eb3586c45ac5ddd7b97ed7 SHA512 4a8a32968e74ed54d700cf65c9cfb238001f58d93a9e374e18d60023615d6277f80459dd8477205ce31a6d8caf798cde70b91681df80b1bff3b754e0586868d2
diff --git a/dev-libs/libqtxdg/libqtxdg-4.0.0.ebuild b/dev-libs/libqtxdg/libqtxdg-4.0.0.ebuild
new file mode 100644
index 000000000000..e24375497207
--- /dev/null
+++ b/dev-libs/libqtxdg/libqtxdg-4.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake optfeature virtualx
+
+DESCRIPTION="Qt Implementation of XDG Standards"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=dev-util/lxqt-build-tools-2.0.0
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-libs/glib:2
+ >=dev-qt/qtbase-6.6:6=[dbus,gui,widgets,xml]
+ >=dev-qt/qtsvg-6.6:6
+ x11-misc/xdg-utils
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Tests don't work with C
+ LC_ALL=en_US.utf8 virtx cmake_src_test
+}
+
+pkg_postinst() {
+ ! has_version lxqt-base/lxqt-meta && optfeature "features that require a terminal emulator" x11-terms/xterm
+}