summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/liblist
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/liblist')
-rw-r--r--dev-libs/liblist/Manifest2
-rw-r--r--dev-libs/liblist/liblist-2.3.1-r1.ebuild54
-rw-r--r--dev-libs/liblist/liblist-2.4.ebuild53
-rw-r--r--dev-libs/liblist/metadata.xml14
4 files changed, 123 insertions, 0 deletions
diff --git a/dev-libs/liblist/Manifest b/dev-libs/liblist/Manifest
new file mode 100644
index 000000000000..5e0b94f046c4
--- /dev/null
+++ b/dev-libs/liblist/Manifest
@@ -0,0 +1,2 @@
+DIST liblist-2.3.1.tar.bz2 257253 SHA256 a956e9c48a5aadecafdc3916eacf2b6cff1eb23e1c40a3119bba2f2a1b4d82a3 SHA512 4bb9cc678bafc3be68f94d028aa9a9a9c9dd792043adc6e7916955afa07b6e94653bd235ee81880307e433e07130823daf1fd36ba0663da7d09e5f4eb84efc6c WHIRLPOOL 511c8453eae6648ef8412168289a8c75dff70ac436984f4d2651a7aaec494b51ead89b639ae2405e23554104a1f08c4660c17bebe8ec9d2d748bc6363ced24f6
+DIST liblist-2.4.tar.bz2 275234 SHA256 ab63d5410952ed3158f1332ce6c17f9ee66241bbc172b811eb573d7db399c836 SHA512 814a02e4e47de8d234e592b87156533c30563c64c3a7515712fb9b75119bcee21796232b2a5abf7e4ab892932fa256890ad175aecb75aad8fb4614c6f4fbe3dd WHIRLPOOL d3ba056c380b251fb0dd9ef0b26b1564ae12483d76960fec95bfaf46dccc7dc4ca5784f874c8b33b294fef9571652d13fba4fa8cfae273536b9bae6bcc552918
diff --git a/dev-libs/liblist/liblist-2.3.1-r1.ebuild b/dev-libs/liblist/liblist-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..2a4f7ab8d037
--- /dev/null
+++ b/dev-libs/liblist/liblist-2.3.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit multilib
+
+DESCRIPTION="This package provides generic linked-list manipulation routines, plus queues and stacks"
+HOMEPAGE="http://ohnopub.net/liblist"
+SRC_URI="ftp://ohnopublishing.net/mirror/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux"
+IUSE="doc examples static-libs"
+
+DEPEND="doc? ( media-gfx/transfig
+ dev-texlive/texlive-metapost
+ virtual/latex-base )"
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable doc docs) \
+ $(use_enable examples) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc README || die
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/{*.c,Makefile,README} || die
+ insinto /usr/share/doc/${PF}/examples/cache
+ doins examples/cache/{*.c,README} || die
+ fi
+
+ if ! use static-libs; then
+ rm -v "${ED}"/usr/$(get_libdir)/liblist.la || die
+ if use examples; then
+ rm -v "${ED}"/usr/$(get_libdir)/libcache.la || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ elog "Note the man pages for this package have been renamed to avoid"
+ elog "name collisions with some system functions, however, the libs"
+ elog "and header files have not been changed."
+ elog "The new names are llist, lcache, lqueue, and lstack."
+}
diff --git a/dev-libs/liblist/liblist-2.4.ebuild b/dev-libs/liblist/liblist-2.4.ebuild
new file mode 100644
index 000000000000..3d870c35eea7
--- /dev/null
+++ b/dev-libs/liblist/liblist-2.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils multilib
+
+DESCRIPTION="This package provides generic linked-list manipulation routines, plus queues and stacks"
+HOMEPAGE="http://ohnopub.net/liblist"
+SRC_URI="ftp://ohnopublishing.net/mirror/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE="doc examples static-libs"
+
+RDEPEND="doc? ( media-gfx/transfig
+ dev-texlive/texlive-metapost
+ virtual/latex-base )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable doc docs)
+ $(use_enable examples)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ dodoc README
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/{*.c,Makefile,README}
+ insinto /usr/share/doc/${PF}/examples/cache
+ doins examples/cache/{*.c,README}
+ fi
+
+ docompress -x /usr/share/doc/${PF}/{list.0,paper.dvi,examples}
+}
+
+pkg_postinst() {
+ elog "Note that man pages for this package have been renamed to avoid"
+ elog "name collisions with some system functions. However, the libs"
+ elog "and header files have not been changed."
+ elog "The new names are liblist, lcache, liblist_queue, and liblist_stack."
+}
diff --git a/dev-libs/liblist/metadata.xml b/dev-libs/liblist/metadata.xml
new file mode 100644
index 000000000000..34c84d91eed5
--- /dev/null
+++ b/dev-libs/liblist/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dev-tools</herd>
+ <maintainer>
+ <email>binki@gentoo.org</email>
+ <name>Nathan Phillip Brink</name>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <longdescription>
+ This package provides generic linked-list manipulation routines. In addition,
+ queue and stack abstractions are provided by single header files.
+ </longdescription>
+</pkgmetadata>