summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-28 21:30:01 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-28 21:39:14 -0400
commite1adde1f6e5afea145a9b9dc37c51ff4d968fdbd (patch)
tree1af9992955129400152b4f30aa5b63fbb2c838f2 /dev-libs/libgweather
parentdev-libs/libgweather: Use python-any-r1 (diff)
downloadgentoo-e1adde1f6e5afea145a9b9dc37c51ff4d968fdbd.tar.gz
gentoo-e1adde1f6e5afea145a9b9dc37c51ff4d968fdbd.tar.bz2
gentoo-e1adde1f6e5afea145a9b9dc37c51ff4d968fdbd.zip
dev-libs/libgweather: Depend on pygobject
Used at build time. Closes: https://bugs.gentoo.org/778839 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/libgweather-40.0.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-libs/libgweather/libgweather-40.0.ebuild b/dev-libs/libgweather/libgweather-40.0.ebuild
index a9e1c0918c24..25aefdc8fd5d 100644
--- a/dev-libs/libgweather/libgweather-40.0.ebuild
+++ b/dev-libs/libgweather/libgweather-40.0.ebuild
@@ -37,6 +37,7 @@ BDEPEND="
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/pygobject[${PYTHON_USEDEP}]')
$(vala_depend)
"
@@ -46,6 +47,10 @@ PATCHES=(
"${FILESDIR}"/40.0-autoskip-network-test.patch
)
+python_check_deps() {
+ has_version -b "dev-python/pygobject[${PYTHON_USEDEP}]"
+}
+
pkg_setup() {
python-any-r1_pkg_setup
}