summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-06-08 20:58:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-06-09 13:18:01 +0200
commit9df404c522e7ae4cd840763b1f43a91ebaf29255 (patch)
treef246e651783289c40c2173830d969388653ee26e /dev-libs/kpublictransport
parentdev-libs/kosmindoormap: 22.04.2 version bump (diff)
downloadgentoo-9df404c522e7ae4cd840763b1f43a91ebaf29255.tar.gz
gentoo-9df404c522e7ae4cd840763b1f43a91ebaf29255.tar.bz2
gentoo-9df404c522e7ae4cd840763b1f43a91ebaf29255.zip
dev-libs/kpublictransport: 22.04.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/kpublictransport')
-rw-r--r--dev-libs/kpublictransport/kpublictransport-22.04.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/kpublictransport/kpublictransport-22.04.2.ebuild b/dev-libs/kpublictransport/kpublictransport-22.04.2.ebuild
new file mode 100644
index 000000000000..e9e30e4aac99
--- /dev/null
+++ b/dev-libs/kpublictransport/kpublictransport-22.04.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+KDE_GEAR="true"
+KFMIN=5.92.0
+QTMIN=5.15.3
+inherit ecm kde.org
+
+DESCRIPTION="Library for accessing public transport timetables and other information"
+HOMEPAGE="https://invent.kde.org/libraries/kpublictransport
+ https://www.volkerkrause.eu/2019/03/02/kpublictransport-introduction.html"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-libs/protobuf:=
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_OsmTools=ON # we have no use for it
+ )
+ ecm_src_configure
+}