summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2023-01-20 09:46:47 +0600
committerSam James <sam@gentoo.org>2023-01-20 03:54:14 +0000
commitad227223cb9511c2f563d95aa06558fddfbe728c (patch)
tree3c35b24be140abeb3aef968cd0f0a88ca3fb2535 /dev-lang
parentsys-fs/ncdu: use "edo" for tests, fix RedirectedUrl (diff)
downloadgentoo-ad227223cb9511c2f563d95aa06558fddfbe728c.tar.gz
gentoo-ad227223cb9511c2f563d95aa06558fddfbe728c.tar.bz2
gentoo-ad227223cb9511c2f563d95aa06558fddfbe728c.zip
dev-lang/zig: drop 0.10.0-r2
It shouldn't be here. Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Closes: https://github.com/gentoo/gentoo/pull/29182 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/zig/zig-0.10.0-r2.ebuild134
1 files changed, 0 insertions, 134 deletions
diff --git a/dev-lang/zig/zig-0.10.0-r2.ebuild b/dev-lang/zig/zig-0.10.0-r2.ebuild
deleted file mode 100644
index f3d9e009df5a..000000000000
--- a/dev-lang/zig/zig-0.10.0-r2.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LLVM_MAX_SLOT=15
-inherit edo cmake llvm check-reqs toolchain-funcs
-
-DESCRIPTION="A robust, optimal, and maintainable programming language"
-HOMEPAGE="https://ziglang.org/"
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/ziglang/zig.git"
- inherit git-r3
-else
- SRC_URI="https://ziglang.org/download/${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-BUILD_DIR="${S}/build"
-
-# Zig requires zstd and zlib compression support in LLVM, if using LLVM backend.
-# (non-LLVM backends don't require these)
-# They are not required "on their own", so please don't add them here.
-# You can check https://github.com/ziglang/zig-bootstrap in future, to see
-# options that are passed to LLVM CMake building (excluding "static" ofc).
-DEPEND="
- sys-devel/clang:${LLVM_MAX_SLOT}=
- sys-devel/lld:${LLVM_MAX_SLOT}=
- sys-devel/llvm:${LLVM_MAX_SLOT}=[zstd]
-"
-
-RDEPEND="
- ${DEPEND}
- !dev-lang/zig-bin
-"
-
-# see https://github.com/ziglang/zig/issues/3382
-# For now, Zig doesn't support CFLAGS/LDFLAGS/etc.
-QA_FLAGS_IGNORED="usr/bin/zig"
-
-# see https://ziglang.org/download/0.10.0/release-notes.html#Self-Hosted-Compiler
-# 0.10.0 release - ~9.6 GiB, since we use compiler written in C++ for bootstrapping
-# 0.11.0 release - ~2.8 GiB, since we will (at least according to roadmap) use self-hosted compiler
-# (transpiled to C via C backend) for bootstrapping
-CHECKREQS_MEMORY="10G"
-
-PATCHES=(
- "${FILESDIR}/${P}-avoid-cmake-bug.patch"
- "${FILESDIR}/${P}-build-dir-install-stage3.patch"
-)
-
-llvm_check_deps() {
- has_version "sys-devel/clang:${LLVM_SLOT}"
-}
-
-ctarget_to_zigtarget() {
- #Zig's Target Format: arch-os-abi
- local CTARGET="${CTARGET:-${CHOST}}"
-
- local ZIG_ARCH
- case "${CTARGET%%-*}" in
- i?86) ZIG_ARCH=x86;;
- sparcv9) ZIG_ARCH=sparc64;;
- *) ZIG_ARCH=${CTARGET%%-*};; # Same as in CHOST
- esac
-
- local ZIG_OS
- case "${CTARGET}" in
- *linux*) ZIG_OS=linux;;
- *apple*) ZIG_OS=macos;;
- esac
-
- local ZIG_ABI
- case "${CTARGET##*-}" in
- gnu) ZIG_ABI="gnu.2.34";;
- solaris*) ZIG_OS=solaris ZIG_ABI=none;;
- darwin*) ZIG_ABI=none;;
- *) ZIG_ABI=${CTARGET##*-};; # Same as in CHOST
- esac
-
- echo "${ZIG_ARCH}-${ZIG_OS}-${ZIG_ABI}"
-}
-
-pkg_setup() {
- llvm_pkg_setup
- ewarn "This version requires 10G of memory for building compiler."
- ewarn "If you don't have enough memory, you can wait until 0.11.0 release"
- ewarn "or (if you are risky) use 9999 version (currently requires only 4GB)"
- check-reqs_pkg_setup
-}
-
-src_configure() {
- local ZIG_MCPU=native
- tc-is-cross-compiler && ZIG_MCPU=baseline
- local mycmakeargs=(
- -DZIG_USE_CCACHE=OFF
- -DZIG_SHARED_LLVM=ON
- -DZIG_TARGET_TRIPLE=$(ctarget_to_zigtarget)
- -DZIG_TARGET_CPU=${ZIG_MCPU}
- -DZIG_USE_LLVM_CONFIG=ON
- -DCMAKE_PREFIX_PATH=$(get_llvm_prefix ${LLVM_MAX_SLOT})
- )
-
- cmake_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}" || die
- local ZIG_TEST_ARGS="-Dstatic-llvm=false -Denable-llvm=true -Dskip-non-native=true -Drelease -Dtarget=native"
- local ZIG_TEST_STEPS=(
- test-cases test-fmt test-behavior test-compiler-rt test-universal-libc test-compare-output
- test-standalone test-c-abi test-link test-stack-traces test-cli test-asm-link test-translate-c
- test-run-translated-c test-std
- )
-
- local step
- for step in "${ZIG_TEST_STEPS[@]}" ; do
- edob ./stage3/bin/zig build ${step} ${ZIG_TEST_ARGS}
- done
-}
-
-pkg_postinst() {
- elog "0.10.0 release introduces self-hosted compiler for general use by default"
- elog "It means that your code can be un-compilable since this compiler has some new or removed features and new or fixed bugs"
- elog "Upstream recommends:"
- elog " * Using old compiler if experiencing such breakage (flag '-fstage1')"
- elog " * Waiting for bugfix release 0.10.1"
- elog " * Waiting for release 0.11.0 with old compiler removed (these changes are already merged in 9999)"
- elog "Also see: https://ziglang.org/download/0.10.0/release-notes.html#Self-Hosted-Compiler"
- elog "and https://ziglang.org/download/0.10.0/release-notes.html#How-to-Upgrade"
-}