summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-09 18:11:11 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 18:13:36 +1000
commit15c0330e55d13576e929bbb36f2bb699bb4ca36e (patch)
tree3cb140f664a1cf6e35707765caa445f012e7d767 /dev-lang
parentprofiles/targets/desktop/gnome: enable gdk-pixbuf by default (diff)
downloadgentoo-15c0330e55d13576e929bbb36f2bb699bb4ca36e.tar.gz
gentoo-15c0330e55d13576e929bbb36f2bb699bb4ca36e.tar.bz2
gentoo-15c0330e55d13576e929bbb36f2bb699bb4ca36e.zip
dev-lang/ruby: finish dropping USE ipv6
The IUSE was accidentally dropped during package QA tidyup. Instead of restoring it we will drop it as superfluous; the fix it applies should not hurt anything and is now unconditional. Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ruby/ruby-3.2.4-r2.ebuild2
-rw-r--r--dev-lang/ruby/ruby-3.2.4-r3.ebuild2
-rw-r--r--dev-lang/ruby/ruby-3.2.5-r1.ebuild2
-rw-r--r--dev-lang/ruby/ruby-3.2.6-r1.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/ruby/ruby-3.2.4-r2.ebuild b/dev-lang/ruby/ruby-3.2.4-r2.ebuild
index 7d109feb42c6..229a1aacf8e0 100644
--- a/dev-lang/ruby/ruby-3.2.4-r2.ebuild
+++ b/dev-lang/ruby/ruby-3.2.4-r2.ebuild
@@ -186,7 +186,7 @@ src_configure() {
fi
# ipv6 hack, bug 168939. Needs --enable-ipv6.
- use ipv6 || myconf="${myconf} --with-lookup-order-hack=INET"
+ myconf="${myconf} --with-lookup-order-hack=INET"
# Determine which modules *not* to build depending in the USE flags.
if ! use berkdb ; then
diff --git a/dev-lang/ruby/ruby-3.2.4-r3.ebuild b/dev-lang/ruby/ruby-3.2.4-r3.ebuild
index 76287f2c4584..1fd84f4d54ed 100644
--- a/dev-lang/ruby/ruby-3.2.4-r3.ebuild
+++ b/dev-lang/ruby/ruby-3.2.4-r3.ebuild
@@ -190,7 +190,7 @@ src_configure() {
fi
# ipv6 hack, bug 168939. Needs --enable-ipv6.
- use ipv6 || myconf="${myconf} --with-lookup-order-hack=INET"
+ myconf="${myconf} --with-lookup-order-hack=INET"
# Determine which modules *not* to build depending in the USE flags.
if ! use berkdb ; then
diff --git a/dev-lang/ruby/ruby-3.2.5-r1.ebuild b/dev-lang/ruby/ruby-3.2.5-r1.ebuild
index 51a1833e9b4f..8216cc259a34 100644
--- a/dev-lang/ruby/ruby-3.2.5-r1.ebuild
+++ b/dev-lang/ruby/ruby-3.2.5-r1.ebuild
@@ -173,7 +173,7 @@ src_configure() {
fi
# ipv6 hack, bug 168939. Needs --enable-ipv6.
- use ipv6 || myconf="${myconf} --with-lookup-order-hack=INET"
+ myconf="${myconf} --with-lookup-order-hack=INET"
# Determine which modules *not* to build depending in the USE flags.
if ! use berkdb ; then
diff --git a/dev-lang/ruby/ruby-3.2.6-r1.ebuild b/dev-lang/ruby/ruby-3.2.6-r1.ebuild
index 74fa2ffc9b24..c5c91c8a1c6c 100644
--- a/dev-lang/ruby/ruby-3.2.6-r1.ebuild
+++ b/dev-lang/ruby/ruby-3.2.6-r1.ebuild
@@ -173,7 +173,7 @@ src_configure() {
fi
# ipv6 hack, bug 168939. Needs --enable-ipv6.
- use ipv6 || myconf="${myconf} --with-lookup-order-hack=INET"
+ myconf="${myconf} --with-lookup-order-hack=INET"
# Determine which modules *not* to build depending in the USE flags.
if ! use berkdb ; then