summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-11-09 20:05:44 +0100
committerTupone Alfredo <tupone@gentoo.org>2019-11-09 20:05:44 +0100
commit056b0b356da86b6a8eecb74ba2989e8fb44dd7a8 (patch)
treec0a60caefb5993eb4793be07d24d40bbf1762217 /dev-lang/spark
parentdev-ada/gps: stable (diff)
downloadgentoo-056b0b356da86b6a8eecb74ba2989e8fb44dd7a8.tar.gz
gentoo-056b0b356da86b6a8eecb74ba2989e8fb44dd7a8.tar.bz2
gentoo-056b0b356da86b6a8eecb74ba2989e8fb44dd7a8.zip
dev-lang/spark: remove old version
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-lang/spark')
-rw-r--r--dev-lang/spark/spark-2018.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-lang/spark/spark-2018.ebuild b/dev-lang/spark/spark-2018.ebuild
deleted file mode 100644
index c6d8008d3a21..000000000000
--- a/dev-lang/spark/spark-2018.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs multiprocessing
-
-MYP=${PN}-gpl-${PV}
-
-DESCRIPTION="Software development for high-reliability applications."
-HOMEPAGE="http://libre.adacore.com"
-SRC_URI="http://mirrors.cdn.adacore.com/art/5b0819dec7a447df26c27a47
- -> ${MYP}-src.tar.gz
- http://mirrors.cdn.adacore.com/art/5b0819dfc7a447df26c27aa5
- -> gnat-gpl-2018-src.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE=""
-
-RDEPEND="dev-lang/gnat-gpl:7.3.1
- dev-ada/gnatcoll-core[gnat_2018,shared]
- sci-mathematics/alt-ergo
- sci-mathematics/why3-for-spark"
-DEPEND="${RDEPEND}
- dev-ada/gprbuild[gnat_2018]"
-
-S="${WORKDIR}"/${MYP}-src
-
-PATCHES=( "${FILESDIR}"/${PN}-2017-gentoo.patch )
-
-src_prepare() {
- ln -sf "${WORKDIR}"/gnat-gpl-2018-src/src/ada gnat2why/gnat_src || die
- default
- GCC_PV=7.3.1
- sed -i \
- -e "s:gnatmake:gnatmake-${GCC_PV}:g" \
- -e "s:gnatls:gnatls-${GCC_PV}:g" \
- Makefile \
- gnatprove/configuration.adb \
- gnat2why/Makefile || die
-}
-
-src_compile() {
- emake GPRARGS="-XLIBRARY_TYPE=relocatable" gnat2why
- emake PROD="-XLIBRARY_TYPE=relocatable" gnatprove
-}
-
-src_install() {
- emake INSTALLDIR="${D}"/usr install
- einstalldocs
- dosym ../../../lib64/why3/why3server /usr/libexec/spark/bin/why3server
- dobin install/bin/gnatprove
- mv install/share/doc/spark/* "${D}"/usr/share/doc/${PF} || die
- exeinto /usr/libexec/spark/bin
- doexe install/bin/gnat2why
- doexe install/bin/spark_memcached_wrapper
- doexe install/bin/spark_report
- doexe install/bin/spark_codepeer_wrapper
- mv "${D}"/usr/bin/target.atp "${D}"/usr/libexec/spark/bin || die
-}