summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-05-31 15:03:38 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-05-31 20:11:10 -0700
commitfbb59a8a651ae791d652f3ccb47168713b9f3b72 (patch)
tree4e3a739c904ae83892b2fb30e3df6b8e159a1969 /dev-lang/rust
parentdev-python/watchgod: Stabilize 0.8.2 arm64, #848675 (diff)
downloadgentoo-fbb59a8a651ae791d652f3ccb47168713b9f3b72.tar.gz
gentoo-fbb59a8a651ae791d652f3ccb47168713b9f3b72.tar.bz2
gentoo-fbb59a8a651ae791d652f3ccb47168713b9f3b72.zip
dev-lang/rust: don't enable profiler for wasm targets
Issue: https://github.com/rust-lang/rust/issues/81684 Closes: https://bugs.gentoo.org/848483 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.60.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.61.0-r1.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/dev-lang/rust/rust-1.60.0.ebuild b/dev-lang/rust/rust-1.60.0.ebuild
index 6a17f74e2327..384775480506 100644
--- a/dev-lang/rust/rust-1.60.0.ebuild
+++ b/dev-lang/rust/rust-1.60.0.ebuild
@@ -420,6 +420,8 @@ src_configure() {
if use wasm; then
cat <<- _EOF_ >> "${S}"/config.toml
[target.wasm32-unknown-unknown]
+ # wasm target does not have profiler_builtins https://bugs.gentoo.org/848483
+ profiler = false
linker = "$(usex system-llvm lld rust-lld)"
_EOF_
fi
diff --git a/dev-lang/rust/rust-1.61.0-r1.ebuild b/dev-lang/rust/rust-1.61.0-r1.ebuild
index 40bfa3387e3e..0d78a06e94e3 100644
--- a/dev-lang/rust/rust-1.61.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.61.0-r1.ebuild
@@ -438,6 +438,8 @@ src_configure() {
cat <<- _EOF_ >> "${S}"/config.toml
[target.wasm32-unknown-unknown]
linker = "$(usex system-llvm lld rust-lld)"
+ # wasm target does not have profiler_builtins https://bugs.gentoo.org/848483
+ profiler = false
_EOF_
fi