summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-06-23 20:47:06 -0600
committerSam James <sam@gentoo.org>2023-06-24 03:58:36 +0100
commit4784c1c318e6fb696cd2ad3736d505a05870594a (patch)
treedccaee78482926626bb79171ccfc52e6f7475844 /dev-lang/rust
parentdev-lang/ocaml: replace `filter-flags -flto*` with `filter-lto` (diff)
downloadgentoo-4784c1c318e6fb696cd2ad3736d505a05870594a.tar.gz
gentoo-4784c1c318e6fb696cd2ad3736d505a05870594a.tar.bz2
gentoo-4784c1c318e6fb696cd2ad3736d505a05870594a.zip
dev-lang/rust: replace `filter-flags -flto*` with `filter-lto`
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.65.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.66.1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.67.1-r1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.68.2.ebuild2
-rw-r--r--dev-lang/rust/rust-1.69.0-r1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.70.0.ebuild2
6 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/rust/rust-1.65.0.ebuild b/dev-lang/rust/rust-1.65.0.ebuild
index d46314607071..5ea43e34fcae 100644
--- a/dev-lang/rust/rust-1.65.0.ebuild
+++ b/dev-lang/rust/rust-1.65.0.ebuild
@@ -307,7 +307,7 @@ src_prepare() {
}
src_configure() {
- filter-flags '-flto*' # https://bugs.gentoo.org/862109 https://bugs.gentoo.org/866231
+ filter-lto # https://bugs.gentoo.org/862109 https://bugs.gentoo.org/866231
local rust_target="" rust_targets="" arch_cflags
diff --git a/dev-lang/rust/rust-1.66.1.ebuild b/dev-lang/rust/rust-1.66.1.ebuild
index 5d39816f9cb7..f20dc1060368 100644
--- a/dev-lang/rust/rust-1.66.1.ebuild
+++ b/dev-lang/rust/rust-1.66.1.ebuild
@@ -305,7 +305,7 @@ src_prepare() {
}
src_configure() {
- filter-flags '-flto*' # https://bugs.gentoo.org/862109 https://bugs.gentoo.org/866231
+ filter-lto # https://bugs.gentoo.org/862109 https://bugs.gentoo.org/866231
local rust_target="" rust_targets="" arch_cflags
diff --git a/dev-lang/rust/rust-1.67.1-r1.ebuild b/dev-lang/rust/rust-1.67.1-r1.ebuild
index 663f1323a4ef..36ce9427fd71 100644
--- a/dev-lang/rust/rust-1.67.1-r1.ebuild
+++ b/dev-lang/rust/rust-1.67.1-r1.ebuild
@@ -296,7 +296,7 @@ src_prepare() {
}
src_configure() {
- filter-flags '-flto*' # https://bugs.gentoo.org/862109 https://bugs.gentoo.org/866231
+ filter-lto # https://bugs.gentoo.org/862109 https://bugs.gentoo.org/866231
local rust_target="" rust_targets="" arch_cflags
diff --git a/dev-lang/rust/rust-1.68.2.ebuild b/dev-lang/rust/rust-1.68.2.ebuild
index 4bf6fa92b305..b8df00c94ecd 100644
--- a/dev-lang/rust/rust-1.68.2.ebuild
+++ b/dev-lang/rust/rust-1.68.2.ebuild
@@ -295,7 +295,7 @@ src_prepare() {
}
src_configure() {
- filter-flags '-flto*' # https://bugs.gentoo.org/862109 https://bugs.gentoo.org/866231
+ filter-lto # https://bugs.gentoo.org/862109 https://bugs.gentoo.org/866231
local rust_target="" rust_targets="" arch_cflags
diff --git a/dev-lang/rust/rust-1.69.0-r1.ebuild b/dev-lang/rust/rust-1.69.0-r1.ebuild
index b312e8a53d1d..888c961ff96a 100644
--- a/dev-lang/rust/rust-1.69.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.69.0-r1.ebuild
@@ -295,7 +295,7 @@ src_prepare() {
}
src_configure() {
- filter-flags '-flto*' # https://bugs.gentoo.org/862109 https://bugs.gentoo.org/866231
+ filter-lto # https://bugs.gentoo.org/862109 https://bugs.gentoo.org/866231
local rust_target="" rust_targets="" arch_cflags
diff --git a/dev-lang/rust/rust-1.70.0.ebuild b/dev-lang/rust/rust-1.70.0.ebuild
index 33820a266181..1f659bb445d7 100644
--- a/dev-lang/rust/rust-1.70.0.ebuild
+++ b/dev-lang/rust/rust-1.70.0.ebuild
@@ -295,7 +295,7 @@ src_prepare() {
}
src_configure() {
- filter-flags '-flto*' # https://bugs.gentoo.org/862109 https://bugs.gentoo.org/866231
+ filter-lto # https://bugs.gentoo.org/862109 https://bugs.gentoo.org/866231
local rust_target="" rust_targets="" arch_cflags