summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/webgraph
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/webgraph')
-rw-r--r--dev-java/webgraph/Manifest1
-rw-r--r--dev-java/webgraph/files/webgraph-1.4.1-gentoo.patch36
-rw-r--r--dev-java/webgraph/metadata.xml11
-rw-r--r--dev-java/webgraph/webgraph-1.4.1-r1.ebuild53
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-java/webgraph/Manifest b/dev-java/webgraph/Manifest
new file mode 100644
index 000000000000..8e03d8d80f33
--- /dev/null
+++ b/dev-java/webgraph/Manifest
@@ -0,0 +1 @@
+DIST webgraph-1.4.1-src.tar.gz 55467 SHA256 a91402ae46c60234f8234a9b05078feb7d23bfa12a68447ef410e24ceb4dc133 SHA512 6c7ae24ad1a3f05d547bd49b83446f42177d50b86db60815208a18fe86129dc1264c9c2d67f6992dd930333e7150b952e27d8cc510179fd362879c719900d5cb WHIRLPOOL 34ba6c65f7051a400eb2de07ff0eaec3cf20fe3b3cb10db927249a3ca269206be990cdb2018101c4695a77e5b8892f77ca18d25e1bd38b4b50d46c9dc30bd666
diff --git a/dev-java/webgraph/files/webgraph-1.4.1-gentoo.patch b/dev-java/webgraph/files/webgraph-1.4.1-gentoo.patch
new file mode 100644
index 000000000000..a4ad2d262a15
--- /dev/null
+++ b/dev-java/webgraph/files/webgraph-1.4.1-gentoo.patch
@@ -0,0 +1,36 @@
+--- build.xml.orig 2005-04-15 14:36:14.000000000 +0200
++++ build.xml 2005-04-15 14:38:45.000000000 +0200
+@@ -19,6 +19,14 @@
+ <property name="jar.base" value="/usr/share/java"/>
+ <property name="javadoc.base" value="/usr/share/javadoc"/>
+
++ <path id="compile.classpath">
++ <pathelement location="lib/jal.jar" />
++ <pathelement location="lib/colt.jar" />
++ <pathelement location="lib/fastutil.jar" />
++ <pathelement location="lib/gnu.getopt.jar" />
++ <pathelement location="lib/mg4j.jar" />
++ </path>
++
+ <!--
+ Groovy and Cobertura need different versions of asm.
+ Due to the delegation-based class-loading model used
+@@ -119,7 +127,9 @@
+ <target name="all" depends="jar,javadoc"/>
+
+ <target name="compile" depends="init" description="Compile standard sources (not test files)">
+- <javac srcdir="${src}" includes="**${subdir}" excludes="test/**" debug="on" optimize="on" destdir="${build}" source="1.4"/>
++ <javac srcdir="${src}" includes="**${subdir}" excludes="test/**" debug="on" optimize="on" destdir="${build}" source="1.4" target="1.4">
++ <classpath refid="compile.classpath" />
++ </javac>
+ </target>
+
+ <target name="jar" depends="compile" description="Creates jar (without tests)">
+@@ -144,6 +154,7 @@
+ <link href="${colt.apiurl}"/>
+ <link href="${jal.apiurl}"/>
+ <link href="${mg4j.apiurl}"/>
++ <classpath refid="compile.classpath" />
+ </javadoc>
+ </target>
+
diff --git a/dev-java/webgraph/metadata.xml b/dev-java/webgraph/metadata.xml
new file mode 100644
index 000000000000..2ff9b03e8808
--- /dev/null
+++ b/dev-java/webgraph/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+WebGraph is a framework to study the web graph. It provides simple ways to
+manage very large graphs, exploiting modern compression techniques.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-java/webgraph/webgraph-1.4.1-r1.ebuild b/dev-java/webgraph/webgraph-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..13d57e54a2e8
--- /dev/null
+++ b/dev-java/webgraph/webgraph-1.4.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="WebGraph is a framework to study the web graph"
+SRC_URI="http://webgraph.dsi.unimi.it/${P}-src.tar.gz"
+HOMEPAGE="http://webgraph.dsi.unimi.it"
+LICENSE="LGPL-2.1"
+SLOT="1.4"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+COMMON_DEP="=dev-java/java-getopt-1.0*
+ =dev-java/fastutil-4.4*
+ =dev-java/colt-1*
+ >=dev-java/jal-20031117
+ =dev-java/mg4j-0.9*"
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ mkdir lib/ && cd lib/
+ java-pkg_jar-from java-getopt-1
+ java-pkg_jar-from fastutil-4.4
+ java-pkg_jar-from colt colt.jar
+ java-pkg_jar-from jal jal.jar
+ java-pkg_jar-from mg4j-0.9
+
+}
+
+src_install() {
+
+ java-pkg_newjar ${P}.jar ${PN}.jar
+
+ dodoc CHANGES
+
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc java/it
+
+}