summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-31 08:58:18 +0100
committerSam James <sam@gentoo.org>2022-05-31 09:03:40 +0100
commit1a02c18680d1802c32f51a003a36fcbb8c1e447d (patch)
treee10ee44b262a951060b374b82a9b67cfb995ebff /dev-java/byaccj
parentdev-python/websockets: Stabilize 10.3 arm, #848687 (diff)
downloadgentoo-1a02c18680d1802c32f51a003a36fcbb8c1e447d.tar.gz
gentoo-1a02c18680d1802c32f51a003a36fcbb8c1e447d.tar.bz2
gentoo-1a02c18680d1802c32f51a003a36fcbb8c1e447d.zip
dev-java/byaccj: fix implicit function declaration
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java/byaccj')
-rw-r--r--dev-java/byaccj/byaccj-1.15-r3.ebuild31
-rw-r--r--dev-java/byaccj/files/byaccj-1.15-implicit-function-declaration.patch15
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-java/byaccj/byaccj-1.15-r3.ebuild b/dev-java/byaccj/byaccj-1.15-r3.ebuild
new file mode 100644
index 000000000000..4db1ab8bbc03
--- /dev/null
+++ b/dev-java/byaccj/byaccj-1.15-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A java extension of BSD YACC-compatible parser generator"
+HOMEPAGE="http://byaccj.sourceforge.net/"
+MY_P="${PN}${PV}_src"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~ppc-macos ~x64-macos"
+
+S="${WORKDIR}/${PN}${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.15-implicit-function-declaration.patch
+)
+
+src_compile() {
+ cp "${FILESDIR}/Makefile" src/Makefile || die
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}" -C src linux
+}
+
+src_install() {
+ newbin src/yacc.linux "${PN}"
+ dodoc docs/ACKNOWLEDGEMEN
+}
diff --git a/dev-java/byaccj/files/byaccj-1.15-implicit-function-declaration.patch b/dev-java/byaccj/files/byaccj-1.15-implicit-function-declaration.patch
new file mode 100644
index 000000000000..5f5bb58db13e
--- /dev/null
+++ b/dev-java/byaccj/files/byaccj-1.15-implicit-function-declaration.patch
@@ -0,0 +1,15 @@
+main.c: In function ‘done’:
+main.c:88:43: error: implicit declaration of function -Werror=implicit-function-declaration
+ 88 | if (action_file) { fclose(action_file); unlink(action_file_name); }
+ | ^~~~~~
+--- a/src/main.c
++++ b/src/main.c
+@@ -2,6 +2,8 @@
+ #include <stdlib.h>
+ #include <string.h>
+
++#include <unistd.h>
++
+ #ifndef __WIN32__ /*rwj -- make portable*/
+ #include <signal.h>
+ #else