summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:53 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:24 +0100
commit61dc45f3210630fba733454f209c61f19a753de4 (patch)
tree137fd425ab78be52ca184d648487d241c5b6a988 /dev-haskell
parentdev-haskell/vector-th-unbox: Migrate to CABAL_CHDEPS (diff)
downloadgentoo-61dc45f3210630fba733454f209c61f19a753de4.tar.gz
gentoo-61dc45f3210630fba733454f209c61f19a753de4.tar.bz2
gentoo-61dc45f3210630fba733454f209c61f19a753de4.zip
dev-haskell/vector: add 0.12.3.1-r1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/vector/Manifest1
-rw-r--r--dev-haskell/vector/files/vector-0.12.3.1-disable-doctests.patch27
-rw-r--r--dev-haskell/vector/metadata.xml66
-rw-r--r--dev-haskell/vector/vector-0.12.3.1-r1.ebuild49
4 files changed, 82 insertions, 61 deletions
diff --git a/dev-haskell/vector/Manifest b/dev-haskell/vector/Manifest
index 6f3189e366f0..6cc95a4e6de1 100644
--- a/dev-haskell/vector/Manifest
+++ b/dev-haskell/vector/Manifest
@@ -1,2 +1,3 @@
DIST vector-0.12.3.1-rev1.cabal 7946 BLAKE2B f1545c06c3a2ce405c9bc498e471b640fa415acd3413fbb3514fd0ea9422f4c7d51ee9ff8b6041da842c45a156132f6eebf89ea11b843835fd360b7c1dafa8f3 SHA512 292df3231e4f34bc038efa769928813808e562553188547420a83a5d068e5d591a169957ef50da42da66b5ba9eea12408b3e739f0f9edb76f06977d6b75a4843
+DIST vector-0.12.3.1-rev4.cabal 8218 BLAKE2B df9e13b1d98377d6506225e3da5a1834c51d3e5244945a6d02a9267b077a5b1d276410130d7c2860b8d49b23f4d6d63dfbd168b497d9ad439240aed19dd8213f SHA512 86088ff4f20b2cc214a703b7ea665baf6d1e9b218f931c6880d6d1291f0dd8e2804863a251a8bf11e82d2f0026d55dcba06f937f8c8909dc8988bc60874374aa
DIST vector-0.12.3.1.tar.gz 151420 BLAKE2B 1d3bb37f1c2b7f3c74e8a934d855b0f1742df03f8526a8b7632d1f940abeeef5a03e476340a96840c9486aeafc404463bff078eb28db9176bc8989b554e87ac4 SHA512 bf117d53c7844c010dc1cee8b778851bd714155fd34e671ae2eb7bd324427de972389eb9f3f315832f20e7bbbecc93ec0f6296ab10e4935957d2a4e14c6cfd98
diff --git a/dev-haskell/vector/files/vector-0.12.3.1-disable-doctests.patch b/dev-haskell/vector/files/vector-0.12.3.1-disable-doctests.patch
new file mode 100644
index 000000000000..1a04dd89c7f0
--- /dev/null
+++ b/dev-haskell/vector/files/vector-0.12.3.1-disable-doctests.patch
@@ -0,0 +1,27 @@
+From eb479f24b766425dd522ba01e0c298fc814c788d Mon Sep 17 00:00:00 2001
+From: hololeap <hololeap@users.noreply.github.com>
+Date: Sat, 4 Mar 2023 14:46:07 -0700
+Subject: [PATCH] Disable doctests
+
+Doctests are not working on ghc-9.2
+
+Signed-off-by: hololeap <hololeap@users.noreply.github.com>
+---
+ vector.cabal | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/vector.cabal b/vector.cabal
+index cea122a..c738a35 100644
+--- a/vector.cabal
++++ b/vector.cabal
+@@ -274,6 +274,7 @@ test-suite vector-tests-O2
+ Ghc-Options: -Wno-redundant-constraints
+
+ test-suite vector-doctest
++ buildable: False
+ type: exitcode-stdio-1.0
+ main-is: doctests.hs
+ hs-source-dirs: tests
+--
+2.39.2
+
diff --git a/dev-haskell/vector/metadata.xml b/dev-haskell/vector/metadata.xml
index f17879fb0804..d7ad3155bea8 100644
--- a/dev-haskell/vector/metadata.xml
+++ b/dev-haskell/vector/metadata.xml
@@ -5,71 +5,15 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- An efficient implementation of Int-indexed arrays (both mutable
- and immutable), with a powerful loop optimisation framework .
-
- It is structured as follows:
-
- ["Data.Vector"] Boxed vectors of arbitrary types.
-
- ["Data.Vector.Unboxed"] Unboxed vectors with an adaptive
- representation based on data type families.
-
- ["Data.Vector.Storable"] Unboxed vectors of 'Storable' types.
-
- ["Data.Vector.Primitive"] Unboxed vectors of primitive types as
- defined by the @primitive@ package. "Data.Vector.Unboxed" is more
- flexible at no performance cost.
-
- ["Data.Vector.Generic"] Generic interface to the vector types.
-
- Each module has a @Safe@ version with is marked as @Trustworthy@
- (see &lt;http://hackage.haskell.org/trac/ghc/wiki/SafeHaskell&gt;).
-
- There is also a (draft) tutorial on common uses of vector.
-
- * &lt;http://haskell.org/haskellwiki/Numeric_Haskell:_A_Vector_Tutorial&gt;
-
- Please use the project trac to submit bug reports and feature
- requests.
-
- * &lt;http://trac.haskell.org/vector&gt;
-
- Changes in version 0.9
-
- * 'MonadPlus' instance for boxed vectors
-
- * Export more @construct@ and @constructN@ from @Safe@ modules
-
- * Require @primitive-0.4.0.1@
-
- Changes in version 0.8
-
- * New functions: @constructN@, @constructrN@
-
- * Support for GHC 7.2 array copying primitives
-
- * New fixity for @(!)@
-
- * Safe Haskell support (contributed by David Terei)
-
- * 'Functor', 'Monad', 'Applicative', 'Alternative', 'Foldable' and
- 'Traversable' instances for boxed vectors
- (/WARNING: they tend to be slow and are only provided for completeness/)
-
- * 'Show' instances for immutable vectors follow containers conventions
-
- * 'Read' instances for all immutable vector types
-
- * Performance improvements
- </longdescription>
<use>
<flag name="boundschecks">Enable bounds checking</flag>
- <flag name="internalchecks">Enable internal consistency checks at the cost of a significant performance penalty</flag>
- <flag name="unsafechecks">Enable bounds checking in unsafe operations at the cost of a significant performance penalty</flag>
+ <flag name="internalchecks">Enable internal consistency checks at the cost of a
+significant performance penalty</flag>
+ <flag name="unsafechecks">Enable bounds checking in unsafe operations at the cost of a
+significant performance penalty</flag>
</use>
<upstream>
+ <remote-id type="hackage">vector</remote-id>
<remote-id type="github">haskell/vector</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/vector/vector-0.12.3.1-r1.ebuild b/dev-haskell/vector/vector-0.12.3.1-r1.ebuild
new file mode 100644
index 000000000000..4cf6adb680e4
--- /dev/null
+++ b/dev-haskell/vector/vector-0.12.3.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.1.0.9999
+#hackport: flags: -wall
+
+CABAL_HACKAGE_REVISION=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient Arrays"
+HOMEPAGE="https://github.com/haskell/vector"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+boundschecks internalchecks unsafechecks"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.12.3.1-disable-doctests.patch"
+)
+
+RDEPEND="
+ >=dev-haskell/primitive-0.6.4.0:=[profile?] <dev-haskell/primitive-0.9:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/base-orphans-0.6
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.9 <dev-haskell/quickcheck-2.15
+ dev-haskell/random
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck
+ )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag boundschecks boundschecks) \
+ $(cabal_flag internalchecks internalchecks) \
+ $(cabal_flag unsafechecks unsafechecks) \
+ --flag=-wall
+}