summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-15 12:41:34 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-15 12:42:12 +0100
commitecf9b506e5ca019e1bd2d716a55e34833991f4e9 (patch)
tree4e67aecc5ce7c895e9bd18341d15223ba9cdc0b8 /dev-haskell/zlib
parentwww-client/seamonkey: Fixed build with USE="system-libvpx" (diff)
downloadgentoo-ecf9b506e5ca019e1bd2d716a55e34833991f4e9.tar.gz
gentoo-ecf9b506e5ca019e1bd2d716a55e34833991f4e9.tar.bz2
gentoo-ecf9b506e5ca019e1bd2d716a55e34833991f4e9.zip
dev-haskell/zlib: bump up to 0.6.2.2
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/zlib')
-rw-r--r--dev-haskell/zlib/Manifest1
-rw-r--r--dev-haskell/zlib/metadata.xml10
-rw-r--r--dev-haskell/zlib/zlib-0.6.2.2.ebuild38
3 files changed, 45 insertions, 4 deletions
diff --git a/dev-haskell/zlib/Manifest b/dev-haskell/zlib/Manifest
index 20505946d824..89598378967c 100644
--- a/dev-haskell/zlib/Manifest
+++ b/dev-haskell/zlib/Manifest
@@ -3,3 +3,4 @@ DIST zlib-0.5.4.2.tar.gz 127818 BLAKE2B 899a0edf39b9830d5223c05dce0d6e4a7884ac12
DIST zlib-0.6.1.1.tar.gz 142902 BLAKE2B 30cc774ca73fd657a9fbb00bda520855cf33932dbeae91c60f900b7c34a57014f14853535d6bd2bf0affbcda3545b896a2bbc1ebe5e289f78140244dd9ea8fb1 SHA512 b9f665308fe7887db376625d6001b5d4c511b6b0f392e366903e84f262cc7c81ed9746d9a5f0b84e9a0ec9dfdc91ed41809528dd50e067008a91ef5168cad12e
DIST zlib-0.6.1.2.tar.gz 142413 BLAKE2B 3dac7acfc11b9e8dd00e7e9b35daa420a34f9cf58d06e7d82fb00f33025b9eb2769b966fdb9772937e8be182b16d502c14e4c6018fbdd72d942b6fca95f7d974 SHA512 0034eb1297eaf20ab64e5cbfc835cee1985d34bc248325bf57f7bf5cdf2918ab72f339fe5b8b3f5f16dee862f190e0c71612960b9021cf2ca70c951788b73fc1
DIST zlib-0.6.2.1.tar.gz 143424 BLAKE2B 2395cb4a87943025088e343036772deae6d2d7a695cf7f6c958a37681e99da9d0a1acbe1f3191cb587d077128b9fe0f6986b3883fbdf91483f83b879b79b3e9d SHA512 cee7942a86afbd08f03c19abd88154cc866a3ccc52342264d4d5b28a71643adf30bf03ba939d6a98b7c065752f9ec326729fc38cfe72b66998551c89186048c5
+DIST zlib-0.6.2.2.tar.gz 148178 BLAKE2B 8de5626a20f4ee2ea0dada54bdddc2340e3c3eba225ac5421a99bee9056aa6aecfd74f609745c4bc238e5cee056e6e463f0851ef7a6d5b0ec3312026f677d912 SHA512 3619b5c32e16a4fb9a68a9e6ea0beb9b14d06a4b5825811f429ee232a0ea13035335cd86c0301f8afcff126a473b86698fd310f9608e0e0ecb849714842be1ea
diff --git a/dev-haskell/zlib/metadata.xml b/dev-haskell/zlib/metadata.xml
index d3253b28407a..45b44ae5f1ea 100644
--- a/dev-haskell/zlib/metadata.xml
+++ b/dev-haskell/zlib/metadata.xml
@@ -6,14 +6,16 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name='non-blocking-ffi'>Execute FFI calls in the context of haskell thread.</flag>
+ <flag name="bundled-c-zlib">Use the bundled zlib C sources. Requires pkg-config to be False. For windows, this is the default.</flag>
+ <flag name="non-blocking-ffi">The (de)compression calls can sometimes take a long time, which prevents other Haskell threads running. Enabling this flag avoids this unfairness, but with greater overall cost.</flag>
</use>
<longdescription>
This package provides a pure interface for compressing and
decompressing streams of data represented as lazy
- 'ByteString's. It uses the zlib C library so it has high
- performance. It supports the \"zlib\", \"gzip\" and \"raw\"
- compression formats.
+ &#39;ByteString&#39;s. It uses the
+ &lt;https://en.wikipedia.org/wiki/Zlib zlib C library&gt;
+ so it has high performance. It supports the \&quot;zlib\&quot;,
+ \&quot;gzip\&quot; and \&quot;raw\&quot; compression formats.
It provides a convenient high level API suitable for most
tasks and for the few cases where more control is needed it
diff --git a/dev-haskell/zlib/zlib-0.6.2.2.ebuild b/dev-haskell/zlib/zlib-0.6.2.2.ebuild
new file mode 100644
index 000000000000..89e0ae099e29
--- /dev/null
+++ b/dev-haskell/zlib/zlib-0.6.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: +pkg-config
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Compression and decompression in the gzip and zlib formats"
+HOMEPAGE="http://hackage.haskell.org/package/zlib"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x86-macos"
+IUSE="bundled-c-zlib non-blocking-ffi"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ virtual/pkgconfig
+ test? ( >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3
+ >=dev-haskell/tasty-0.8 <dev-haskell/tasty-1.3
+ >=dev-haskell/tasty-hunit-0.8 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.11 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag bundled-c-zlib bundled-c-zlib) \
+ $(cabal_flag non-blocking-ffi non-blocking-ffi) \
+ --flag=pkg-config
+}