summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/zip-archive
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/zip-archive')
-rw-r--r--dev-haskell/zip-archive/Manifest2
-rw-r--r--dev-haskell/zip-archive/metadata.xml15
-rw-r--r--dev-haskell/zip-archive/zip-archive-0.1.3.4.ebuild36
-rw-r--r--dev-haskell/zip-archive/zip-archive-0.2.3.7.ebuild38
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-haskell/zip-archive/Manifest b/dev-haskell/zip-archive/Manifest
new file mode 100644
index 000000000000..188cd9c7a7bb
--- /dev/null
+++ b/dev-haskell/zip-archive/Manifest
@@ -0,0 +1,2 @@
+DIST zip-archive-0.1.3.4.tar.gz 11250 SHA256 cbef41120d995a87702f7bb0c1ed8107f3f36a61714b2e31d9d19df5466e7643 SHA512 8476041bd3674a42c3777c54243037162d3fdf6f8e0c0bcb9577a4cd76a41d6d9dbdddc482845256858b284bd2bb6ad06cce8208c5584e60553ae659386f8165 WHIRLPOOL bad2e6c33f1de58a964a808c0830d3064270b2e74e91557eef83819ab1b5d6a70a07cf924ae74ce863017b7ae07f8a4c3e8faf0c368d4ca4e7f6972be5a99bd8
+DIST zip-archive-0.2.3.7.tar.gz 12902 SHA256 41623b3831795e785329b017f42af3116f6332a690361f7eac7ed15f729f3699 SHA512 3849a9ac806d69b496bfd2973ba8908b981cd72f900565fc9aea8a2b4080ec7c6fe8c579158c22da0ddc398faecf77a7ae1793eecf4d3054d0bdc06fde2aa7cc WHIRLPOOL c1f25fc21a5a34a9f3709e03d4c6ba684eae95d1a895366008a1d32df456c402e890ebcc265617db0b5299b3e04bbef3547c43a74111438175bbfc5e91d5075d
diff --git a/dev-haskell/zip-archive/metadata.xml b/dev-haskell/zip-archive/metadata.xml
new file mode 100644
index 000000000000..dc57badf80c0
--- /dev/null
+++ b/dev-haskell/zip-archive/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ The zip-archive library provides functions for creating, modifying,
+ and extracting files from zip archives.
+ </longdescription>
+ <use>
+ <flag name="executable">Build the Zip executable.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">jgm/zip-archive</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/zip-archive/zip-archive-0.1.3.4.ebuild b/dev-haskell/zip-archive/zip-archive-0.1.3.4.ebuild
new file mode 100644
index 000000000000..4789ddfc051b
--- /dev/null
+++ b/dev-haskell/zip-archive/zip-archive-0.1.3.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Library for creating and modifying zip archives"
+HOMEPAGE="http://github.com/jgm/zip-archive"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/binary-0.5:=[profile?]
+ >=dev-haskell/digest-0.0.0.1:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/utf8-string-0.3.1:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-7.0.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/hunit
+ app-arch/zip
+ )"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}
diff --git a/dev-haskell/zip-archive/zip-archive-0.2.3.7.ebuild b/dev-haskell/zip-archive/zip-archive-0.2.3.7.ebuild
new file mode 100644
index 000000000000..c512e302adab
--- /dev/null
+++ b/dev-haskell/zip-archive/zip-archive-0.2.3.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Library for creating and modifying zip archives"
+HOMEPAGE="http://github.com/jgm/zip-archive"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/binary-0.5:=[profile?]
+ >=dev-haskell/digest-0.0.0.1:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( app-arch/zip
+ dev-haskell/hunit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}