summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-12 17:41:53 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:41 +0000
commit8ba8143bc4a8132b4782d4f6406fd99e86608364 (patch)
tree51425be79032ca5f49a8d62d0ffad6ed34d656d7 /dev-haskell/should-not-typecheck
parentdev-haskell/sha: keyword 1.6.4.4 for ~ppc64 (diff)
downloadgentoo-8ba8143bc4a8132b4782d4f6406fd99e86608364.tar.gz
gentoo-8ba8143bc4a8132b4782d4f6406fd99e86608364.tar.bz2
gentoo-8ba8143bc4a8132b4782d4f6406fd99e86608364.zip
dev-haskell/should-not-typecheck: new package, add 2.1.0
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/should-not-typecheck')
-rw-r--r--dev-haskell/should-not-typecheck/Manifest1
-rw-r--r--dev-haskell/should-not-typecheck/metadata.xml11
-rw-r--r--dev-haskell/should-not-typecheck/should-not-typecheck-2.1.0.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/should-not-typecheck/Manifest b/dev-haskell/should-not-typecheck/Manifest
new file mode 100644
index 000000000000..751f92de99a5
--- /dev/null
+++ b/dev-haskell/should-not-typecheck/Manifest
@@ -0,0 +1 @@
+DIST should-not-typecheck-2.1.0.tar.gz 5229 BLAKE2B 66d08f52a72dc40ef549fdd724889937506d1836eb60fecd8d55801287504586718e14d91d5be8c0e49e6b382281e3eea32757001ba0f4dc446ef063fd024ec8 SHA512 46ba4435a4408e23dfe6e04f827a7efcfd3c94a4a53a0562061d5cd40c11fcbae7569e695329fe98f9d9ecea1999ac68da6594d2ca60c2efccdac2d6d674d65d
diff --git a/dev-haskell/should-not-typecheck/metadata.xml b/dev-haskell/should-not-typecheck/metadata.xml
new file mode 100644
index 000000000000..251a5fbd2ee8
--- /dev/null
+++ b/dev-haskell/should-not-typecheck/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ For examples and an introduction to the library please take a look at the &lt;https://github.com/CRogers/should-not-typecheck#should-not-typecheck- README&gt; on github.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/should-not-typecheck/should-not-typecheck-2.1.0.ebuild b/dev-haskell/should-not-typecheck/should-not-typecheck-2.1.0.ebuild
new file mode 100644
index 000000000000..69598288c555
--- /dev/null
+++ b/dev-haskell/should-not-typecheck/should-not-typecheck-2.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A HUnit/hspec assertion library to verify that an expression does not typecheck"
+HOMEPAGE="https://github.com/CRogers/should-not-typecheck"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hunit-1.2:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/hspec-2.1
+ >=dev-haskell/hspec-expectations-0.6 )
+"