summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/regex-applicative
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/regex-applicative')
-rw-r--r--dev-haskell/regex-applicative/Manifest2
-rw-r--r--dev-haskell/regex-applicative/metadata.xml12
-rw-r--r--dev-haskell/regex-applicative/regex-applicative-0.3.1.ebuild30
-rw-r--r--dev-haskell/regex-applicative/regex-applicative-0.3.2.1.ebuild30
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-haskell/regex-applicative/Manifest b/dev-haskell/regex-applicative/Manifest
new file mode 100644
index 000000000000..8f35b4785a21
--- /dev/null
+++ b/dev-haskell/regex-applicative/Manifest
@@ -0,0 +1,2 @@
+DIST regex-applicative-0.3.1.tar.gz 12627 SHA256 1eb8d5b2fb20f2d30180e0d1a2bbe1aba9890864e2bac3907bf6ba1f408895ce SHA512 2b61679aa3bdee09810a872e75583bf8b050d00050b8a1a5fe226337cdcae2d1a1ca31139d4006f442b4d8c3a78206dbff7c1bfbd480beec7d30b4ea9aeacf8c WHIRLPOOL 3e08105ef4691cf78049327ef6c799f0ce260ef7531fb92082d642056cf6dfbf69276ddc756e1e89079f84f01ca89c443adcd41b8bf4bfd51e082b6ce16603d1
+DIST regex-applicative-0.3.2.1.tar.gz 13531 SHA256 bf4ab2dc765d8083ac08a72b2221712a942a734b90e4ce433baf4b5c8db35ca7 SHA512 03f83bf514952055ef27edc6d04c7969a085ca9fe458117c401cfdd83fd7e12c6969a90199d094f20a4bbabeb8055a70043b08b2149c92b477ceecd5cc80ed1d WHIRLPOOL 828a57b06acbaa630ec7091b9bb90840c5ee6d96b092896a7ed30de0cd755feaa8eea6abc05b233f2ed2239c1fad084a1fc8e36e13230451dfd18a7a6bd37e07
diff --git a/dev-haskell/regex-applicative/metadata.xml b/dev-haskell/regex-applicative/metadata.xml
new file mode 100644
index 000000000000..1059fd4b074a
--- /dev/null
+++ b/dev-haskell/regex-applicative/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ regex-applicative is a Haskell library for parsing using regular expressions.
+ Parsers can be built using Applicative interface.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">feuerbach/regex-applicative</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/regex-applicative/regex-applicative-0.3.1.ebuild b/dev-haskell/regex-applicative/regex-applicative-0.3.1.ebuild
new file mode 100644
index 000000000000..1218d7700813
--- /dev/null
+++ b/dev-haskell/regex-applicative/regex-applicative-0.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Regex-based parsing with applicative interface"
+HOMEPAGE="https://github.com/feuerbach/regex-applicative"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/smallcheck-1.0
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-smallcheck )
+"
diff --git a/dev-haskell/regex-applicative/regex-applicative-0.3.2.1.ebuild b/dev-haskell/regex-applicative/regex-applicative-0.3.2.1.ebuild
new file mode 100644
index 000000000000..1218d7700813
--- /dev/null
+++ b/dev-haskell/regex-applicative/regex-applicative-0.3.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Regex-based parsing with applicative interface"
+HOMEPAGE="https://github.com/feuerbach/regex-applicative"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/smallcheck-1.0
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-smallcheck )
+"