summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 17:43:06 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:36 +0000
commit50ff23330a137905b8b9419436e1bd920b89ad56 (patch)
treeeb85891de7d61e83c2abad7305efb43007fe4d88 /dev-haskell/random
parentdev-haskell/quickcheck-io: keyword 0.2.0 for ~ppc64 (diff)
downloadgentoo-50ff23330a137905b8b9419436e1bd920b89ad56.tar.gz
gentoo-50ff23330a137905b8b9419436e1bd920b89ad56.tar.bz2
gentoo-50ff23330a137905b8b9419436e1bd920b89ad56.zip
dev-haskell/random: add 1.2.1
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/random')
-rw-r--r--dev-haskell/random/Manifest1
-rw-r--r--dev-haskell/random/random-1.2.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-haskell/random/Manifest b/dev-haskell/random/Manifest
index 45fc2dd8247d..b234c5e28d8d 100644
--- a/dev-haskell/random/Manifest
+++ b/dev-haskell/random/Manifest
@@ -1 +1,2 @@
DIST random-1.1.tar.gz 10870 BLAKE2B e26794bf5dd05b39bdd92afb55abde54d35ff4f7116753ff8b901c8cc18ea71a73fbcb5fc7c1c4a2d35f33ebcf1a3dbbdc0018cb2f8fb1978c35960b95e90606 SHA512 7f128b1c88adfe7ee6405578d3c999bb77e9e3c21e16f82a5197c0ad1d6731851e99e08d8169c6a8b1068ad8a1614c1c0ef8c04c1958337a6e325f1de0c718a3
+DIST random-1.2.1.tar.gz 47143 BLAKE2B 861a216b063aa893a9de645cca231fb1a1914609ea4dd8ec222b35db6ee9cc60760a613896e979f731d3e1a55ea792a294d380313e78549c6effc21b77d57564 SHA512 b130a90981de53b4fc3e7cf660224268d24bcceb9498d33827d9f43dc705c9a724c23999c4cf0222127f4c69daebf0d049d963abbea0a860135d661f9cc55731
diff --git a/dev-haskell/random/random-1.2.1.ebuild b/dev-haskell/random/random-1.2.1.ebuild
new file mode 100644
index 000000000000..5b06d7481e13
--- /dev/null
+++ b/dev-haskell/random/random-1.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite circular depend
+inherit haskell-cabal
+
+DESCRIPTION="Pseudo-random number generation"
+HOMEPAGE="https://hackage.haskell.org/package/random"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+# circular depend: random[test]->mwc-random->math-functions[test]->vector-th-unbox->vector->random
+RESTRICT=test
+
+RDEPEND=">=dev-haskell/mtl-2.2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/splitmix-0.1:=[profile?] <dev-haskell/splitmix-0.2:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1"