summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-09-11 10:52:33 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-09-11 11:01:39 +0100
commitbc5f09fec0e90b326a5f5e02d3801857c6b29ee9 (patch)
treea7526f12d0e8e45674699286e912c34108df54bb /dev-haskell/language-python/language-python-0.5.4.ebuild
parentdev-haskell/language-lua: parser and pretty-printer for lua, a depend of app-... (diff)
downloadgentoo-bc5f09fec0e90b326a5f5e02d3801857c6b29ee9.tar.gz
gentoo-bc5f09fec0e90b326a5f5e02d3801857c6b29ee9.tar.bz2
gentoo-bc5f09fec0e90b326a5f5e02d3801857c6b29ee9.zip
dev-haskell/language-python: parser and pretty-printer for python, a depend of app-forensics/quickfuzz
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-haskell/language-python/language-python-0.5.4.ebuild')
-rw-r--r--dev-haskell/language-python/language-python-0.5.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-haskell/language-python/language-python-0.5.4.ebuild b/dev-haskell/language-python/language-python-0.5.4.ebuild
new file mode 100644
index 000000000000..393f8634b0d8
--- /dev/null
+++ b/dev-haskell/language-python/language-python-0.5.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Parsing and pretty printing of Python code"
+HOMEPAGE="https://github.com/bjpop/language-python"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/monads-tf-0.1:=[profile?] <dev-haskell/monads-tf-0.2:=[profile?]
+ >=dev-haskell/utf8-string-1:=[profile?] <dev-haskell/utf8-string-2:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.18.1.3
+ dev-haskell/happy
+"