summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-04-21 08:35:24 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-04-21 08:40:23 +0100
commit41839753a15b50e0d37247aaadcc1c3a3e852226 (patch)
treea3fabfd9e95e787e2c0ddda31dad7bf85e2dc66b /dev-haskell/filepattern
parentsys-fs/exfatprogs: Removed old (diff)
downloadgentoo-41839753a15b50e0d37247aaadcc1c3a3e852226.tar.gz
gentoo-41839753a15b50e0d37247aaadcc1c3a3e852226.tar.bz2
gentoo-41839753a15b50e0d37247aaadcc1c3a3e852226.zip
dev-haskell/filepattern: new package, a depend of hlint-3
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/filepattern')
-rw-r--r--dev-haskell/filepattern/Manifest1
-rw-r--r--dev-haskell/filepattern/filepattern-0.1.2.ebuild27
-rw-r--r--dev-haskell/filepattern/metadata.xml26
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/filepattern/Manifest b/dev-haskell/filepattern/Manifest
new file mode 100644
index 000000000000..b239371aaa91
--- /dev/null
+++ b/dev-haskell/filepattern/Manifest
@@ -0,0 +1 @@
+DIST filepattern-0.1.2.tar.gz 15737 BLAKE2B c90064a18115538cf7e1d5b26cb46971b86b0c7fb4f8e503db7cf7097cf1f19c8c1fdc3e89a0a90dbf915c95b71109359e94ad8f225a4cb450ad6a5fa71994d7 SHA512 16866d70efdf55ee4e6b246eb7f7300c9ad4c148d8136d817f601b9c0cac95eb1ddaf57ab0b6fad539298b55128fe5c255c31fd152a713bf312488eae823da23
diff --git a/dev-haskell/filepattern/filepattern-0.1.2.ebuild b/dev-haskell/filepattern/filepattern-0.1.2.ebuild
new file mode 100644
index 000000000000..148807303154
--- /dev/null
+++ b/dev-haskell/filepattern/filepattern-0.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="File path glob-like matching"
+HOMEPAGE="https://github.com/ndmitchell/filepattern#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/extra-1.6.2:=[profile?]
+ >=dev-haskell/semigroups-0.18:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18
+ test? ( >=dev-haskell/quickcheck-2.0 )
+"
diff --git a/dev-haskell/filepattern/metadata.xml b/dev-haskell/filepattern/metadata.xml
new file mode 100644
index 000000000000..9b145f120dc0
--- /dev/null
+++ b/dev-haskell/filepattern/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A library for matching files using patterns such as @\&quot;src\/**\/*.png\&quot;@ for all @.png@ files
+ recursively under the @src@ directory. Features:
+
+ * All matching is /O(n)/.
+
+ * See &quot;System.FilePattern&quot; and @?==@ simple matching and semantics.
+
+ * Use @match@ and @substitute@ to extract suitable
+ strings from the @*@ and @**@ matches, and substitute them back into other patterns.
+
+ * Use @step@ and @matchMany@ to perform bulk matching
+ of many patterns against many paths simultaneously.
+
+ * Use &quot;System.FilePattern.Directory&quot; to perform optimised directory traverals using patterns.
+
+ Originally taken from the &lt;https://hackage.haskell.org/package/shake Shake library&gt;.
+ </longdescription>
+</pkgmetadata>