summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-08 21:48:24 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 16:13:47 +0100
commitcdc0774a75c8eecd1d68d2b0b1687884b88b9331 (patch)
tree9b77a5773bcffa670927e93a4a1d38456520b488 /dev-haskell/criterion
parentapp-i18n/man-pages-pl: drop old EAPI (diff)
downloadgentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.gz
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.bz2
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.zip
*/*: Inline mirror://hackage and update URIs
This change inlines mirror://hackage in all ebuilds, and updates URIs to the modern form (old URIs redirect to that). The change has been made using the following command: find -name '*.ebuild' -exec sed -r -i \ -e 's@mirror://hackage/@https://hackage.haskell.org/@g' \ -e 's@https://hackage.haskell.org/packages/archive/([^/]*)/([^/]*)/@https://hackage.haskell.org/package/\1-\2/@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{PV}@${P}@g' \ -e '/hackage\.haskell\.org/s@\$\{MY_PN}-\$\{PV}@${MY_P}@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{MY_PV}@${MY_P}@g' \ {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-haskell/criterion')
-rw-r--r--dev-haskell/criterion/criterion-0.8.1.0.ebuild4
-rw-r--r--dev-haskell/criterion/criterion-1.0.2.0.ebuild4
-rw-r--r--dev-haskell/criterion/criterion-1.1.0.0.ebuild4
-rw-r--r--dev-haskell/criterion/criterion-1.1.1.0.ebuild4
-rw-r--r--dev-haskell/criterion/criterion-1.1.4.0.ebuild4
5 files changed, 10 insertions, 10 deletions
diff --git a/dev-haskell/criterion/criterion-0.8.1.0.ebuild b/dev-haskell/criterion/criterion-0.8.1.0.ebuild
index 46f90471c2b8..bdb1e5227df0 100644
--- a/dev-haskell/criterion/criterion-0.8.1.0.ebuild
+++ b/dev-haskell/criterion/criterion-0.8.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Robust, reliable performance measurement and analysis"
HOMEPAGE="https://github.com/bos/criterion"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/criterion/criterion-1.0.2.0.ebuild b/dev-haskell/criterion/criterion-1.0.2.0.ebuild
index b080fc751f88..67bd2a16b403 100644
--- a/dev-haskell/criterion/criterion-1.0.2.0.ebuild
+++ b/dev-haskell/criterion/criterion-1.0.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Robust, reliable performance measurement and analysis"
HOMEPAGE="http://www.serpentine.com/criterion"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/criterion/criterion-1.1.0.0.ebuild b/dev-haskell/criterion/criterion-1.1.0.0.ebuild
index 19817c905704..189ff62eb5fb 100644
--- a/dev-haskell/criterion/criterion-1.1.0.0.ebuild
+++ b/dev-haskell/criterion/criterion-1.1.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Robust, reliable performance measurement and analysis"
HOMEPAGE="http://www.serpentine.com/criterion"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/criterion/criterion-1.1.1.0.ebuild b/dev-haskell/criterion/criterion-1.1.1.0.ebuild
index a297c7902491..717002631465 100644
--- a/dev-haskell/criterion/criterion-1.1.1.0.ebuild
+++ b/dev-haskell/criterion/criterion-1.1.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="Robust, reliable performance measurement and analysis"
HOMEPAGE="http://www.serpentine.com/criterion"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/criterion/criterion-1.1.4.0.ebuild b/dev-haskell/criterion/criterion-1.1.4.0.ebuild
index fbd90465be55..0b9207692521 100644
--- a/dev-haskell/criterion/criterion-1.1.4.0.ebuild
+++ b/dev-haskell/criterion/criterion-1.1.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,7 +11,7 @@ inherit haskell-cabal
DESCRIPTION="Robust, reliable performance measurement and analysis"
HOMEPAGE="http://www.serpentine.com/criterion"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"