summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-12 16:31:38 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:00 +0000
commit9c348d9713b38140b52415227ccbbe53df8177d1 (patch)
tree4c077ef9caf42ae0e5e139ce7d847762ad7b2e9b /dev-haskell/constraints/constraints-0.13.3.ebuild
parentdev-haskell/connection: keyword 0.3.1 for ~ppc64 (diff)
downloadgentoo-9c348d9713b38140b52415227ccbbe53df8177d1.tar.gz
gentoo-9c348d9713b38140b52415227ccbbe53df8177d1.tar.bz2
gentoo-9c348d9713b38140b52415227ccbbe53df8177d1.zip
dev-haskell/constraints: add 0.13.3
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/constraints/constraints-0.13.3.ebuild')
-rw-r--r--dev-haskell/constraints/constraints-0.13.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-haskell/constraints/constraints-0.13.3.ebuild b/dev-haskell/constraints/constraints-0.13.3.ebuild
new file mode 100644
index 000000000000..90010741f1d4
--- /dev/null
+++ b/dev-haskell/constraints/constraints-0.13.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Constraint manipulation"
+HOMEPAGE="https://github.com/ekmett/constraints/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/hashable-1.2:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/transformers-compat-0.5:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-haskell/type-equality-1:=[profile?] <dev-haskell/type-equality-2:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hspec-2 )
+"