summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 11:47:05 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:02:49 +0100
commit71b63433d3d0f3a7d86cb9bc0c21adb428bd6e4e (patch)
tree7dfc342dee6b3d3a55534e2d9a469b150b992444 /dev-haskell/cipher-aes128
parentdev-haskell/authenticate-oauth: add package (diff)
downloadgentoo-71b63433d3d0f3a7d86cb9bc0c21adb428bd6e4e.tar.gz
gentoo-71b63433d3d0f3a7d86cb9bc0c21adb428bd6e4e.tar.bz2
gentoo-71b63433d3d0f3a7d86cb9bc0c21adb428bd6e4e.zip
dev-haskell/cipher-aes128: add package
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/cipher-aes128')
-rw-r--r--dev-haskell/cipher-aes128/Manifest1
-rw-r--r--dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r1.ebuild41
-rw-r--r--dev-haskell/cipher-aes128/files/cipher-aes128-0.7.0.3-ghc-8.6.patch16
-rw-r--r--dev-haskell/cipher-aes128/metadata.xml15
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-haskell/cipher-aes128/Manifest b/dev-haskell/cipher-aes128/Manifest
new file mode 100644
index 000000000000..f4340e1ff714
--- /dev/null
+++ b/dev-haskell/cipher-aes128/Manifest
@@ -0,0 +1 @@
+DIST cipher-aes128-0.7.0.5.tar.gz 26228 BLAKE2B 8ef1aa343563d7889154b5f0b96b5b457ed21afbcad4f90f82e95a080c19f50d8ad2500ef4b8caa1509ca953aba3ca1941c61656417ed527943858a9d6cfd652 SHA512 8479dec68d6fa35e8d615bcc8c6336459fa537f1962b7af87e63b0c38d544ed26e6d30e980f90bb3585513bd618e01330d3e008e77404dae8d2e27954d7a535a
diff --git a/dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r1.ebuild b/dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r1.ebuild
new file mode 100644
index 000000000000..fea7988f16ec
--- /dev/null
+++ b/dev-haskell/cipher-aes128/cipher-aes128-0.7.0.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2
+#hackport: flags: -test,-halvm
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="AES and common modes using AES-NI when available"
+HOMEPAGE="https://github.com/TomMD/cipher-aes128"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/cereal:=[profile?]
+ >=dev-haskell/crypto-api-0.13:=[profile?]
+ dev-haskell/tagged:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3 <dev-haskell/cabal-3.3
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'Cabal >= 1.10 && < 3.1' 'Cabal >= 1.10 && < 3.3'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-halvm \
+ --flag=-test
+}
diff --git a/dev-haskell/cipher-aes128/files/cipher-aes128-0.7.0.3-ghc-8.6.patch b/dev-haskell/cipher-aes128/files/cipher-aes128-0.7.0.3-ghc-8.6.patch
new file mode 100644
index 000000000000..a5d056e71c94
--- /dev/null
+++ b/dev-haskell/cipher-aes128/files/cipher-aes128-0.7.0.3-ghc-8.6.patch
@@ -0,0 +1,16 @@
+diff -ru cipher-aes128-0.7.0.3.orig/Setup.hs cipher-aes128-0.7.0.3/Setup.hs
+--- cipher-aes128-0.7.0.3.orig/Setup.hs 2016-08-31 01:58:48.000000000 -0400
++++ cipher-aes128-0.7.0.3/Setup.hs 2018-07-04 22:06:10.880373751 -0400
+@@ -13,10 +13,8 @@
+ main = defaultMainWithHooks hk
+ where
+ hk = simpleUserHooks { buildHook = \pd lbi uh bf -> do
+- let ccProg = Program "gcc" undefined undefined undefined
+- hcProg = Program "ghc" undefined undefined undefined
+- mConf = lookupProgram ccProg (withPrograms lbi)
+- hcConf = lookupProgram hcProg (withPrograms lbi)
++ let mConf = lookupProgram gccProgram (withPrograms lbi)
++ hcConf = lookupProgram ghcProgram (withPrograms lbi)
+ err = error "Could not determine C compiler"
+ _cc = locationPath . programLocation . maybe err id $ mConf
+ hc = locationPath . programLocation . maybe err id $ hcConf
diff --git a/dev-haskell/cipher-aes128/metadata.xml b/dev-haskell/cipher-aes128/metadata.xml
new file mode 100644
index 000000000000..3c77a6d727ea
--- /dev/null
+++ b/dev-haskell/cipher-aes128/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Cipher-aes128 is an implementation of AES and common modes of operation. It borrows Hanquez's C AES code (see 'cipher-aes') but
+ is unique due to including compile-time detection of
+ NI compiler support, a slightly more functional interface
+ for GCM operations, exposure of 'Ptr' based operations via the .Internal module, and build-in crypto-api support.
+ Cipher-aes128 was originally developed as "'cipher-aes' plus trampolines", which has since been adopted into cipher-aes.
+ </longdescription>
+</pkgmetadata>