summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-01-14 14:18:46 +0000
committerJames Le Cuirot <chewi@gentoo.org>2024-01-14 14:56:47 +0000
commitc3172402ee77d82ed5b9180ebaa5c43b7516aefc (patch)
treea1f551caf797e74ef8078ae6b3d0562fa1ed9c90 /dev-embedded
parentapp-misc/skim: add 0.10.4 (diff)
downloadgentoo-c3172402ee77d82ed5b9180ebaa5c43b7516aefc.tar.gz
gentoo-c3172402ee77d82ed5b9180ebaa5c43b7516aefc.tar.bz2
gentoo-c3172402ee77d82ed5b9180ebaa5c43b7516aefc.zip
dev-embedded/raspberrypi-utils: New package
This replaces media-libs/raspberrypi-userland(-bin), which is being last-rited. The libraries are no longer maintained, but the utilities live on here. Bug: https://bugs.gentoo.org/916953 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/raspberrypi-utils/Manifest1
-rw-r--r--dev-embedded/raspberrypi-utils/metadata.xml11
-rw-r--r--dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240112.ebuild39
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-embedded/raspberrypi-utils/Manifest b/dev-embedded/raspberrypi-utils/Manifest
new file mode 100644
index 000000000000..415e4b801a0e
--- /dev/null
+++ b/dev-embedded/raspberrypi-utils/Manifest
@@ -0,0 +1 @@
+DIST raspberrypi-utils-0_p20240112.tar.gz 122544 BLAKE2B ccdd25aca03b3a09d1d6a6007a80b3615ec8bc5fabcb7e5b7fedd09d68f992e587e90bf4fa36b7131090438fbd8706f7184d70018aadad05a1a9d897282d6c0f SHA512 6d3aa77499ef88ffc33b364267021822c64554ccf9226537e862ceed52cdf3557ec42a45be3618ca2828dfe0cddb901a09f0cddf7fa07946536713996f6b2cc0
diff --git a/dev-embedded/raspberrypi-utils/metadata.xml b/dev-embedded/raspberrypi-utils/metadata.xml
new file mode 100644
index 000000000000..11b4d811a352
--- /dev/null
+++ b/dev-embedded/raspberrypi-utils/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">raspberrypi/utils</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240112.ebuild b/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240112.ebuild
new file mode 100644
index 000000000000..9628a77098f0
--- /dev/null
+++ b/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240112.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 cmake
+
+COMMIT="193e6e34b40807cbeedee2e4abc3ef5165e14ae2"
+
+DESCRIPTION="Raspberry Pi userspace utilities"
+HOMEPAGE="https://github.com/raspberrypi/utils"
+SRC_URI="https://github.com/raspberrypi/utils/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~arm ~arm64"
+
+RDEPEND="
+ !media-libs/raspberrypi-userland
+ !media-libs/raspberrypi-userland-bin
+"
+
+S="${WORKDIR}/utils-${COMMIT}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ local SRC
+ rm -r "${ED}"/usr/share/bash-completion/ || die
+ for SRC in */*-completion.bash; do
+ local DEST=${SRC%-completion.bash}
+ newbashcomp "${SRC}" "${DEST##*/}"
+ done
+}