summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2024-01-28 23:34:00 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-02-28 08:55:11 +0200
commita8133b9b86904388855b62cf46464abe560abcde (patch)
treee590725ded378c77afe1f735767d1380fb0fe653 /dev-embedded
parentgui-libs/gtk-layer-shell: drop 0.8.0 (diff)
downloadgentoo-a8133b9b86904388855b62cf46464abe560abcde.tar.gz
gentoo-a8133b9b86904388855b62cf46464abe560abcde.tar.bz2
gentoo-a8133b9b86904388855b62cf46464abe560abcde.zip
dev-embedded/esptool: drop 3.3.3, 4.5.1, 4.6.1
Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/esptool/Manifest3
-rw-r--r--dev-embedded/esptool/esptool-3.3.3.ebuild47
-rw-r--r--dev-embedded/esptool/esptool-4.5.1.ebuild64
-rw-r--r--dev-embedded/esptool/esptool-4.6.1.ebuild65
4 files changed, 0 insertions, 179 deletions
diff --git a/dev-embedded/esptool/Manifest b/dev-embedded/esptool/Manifest
index b0b5978dd5b1..019eb7d41ed6 100644
--- a/dev-embedded/esptool/Manifest
+++ b/dev-embedded/esptool/Manifest
@@ -1,4 +1 @@
-DIST esptool-3.3.3.tar.gz 7264378 BLAKE2B 8c993bd4ccffaf417599daebcb08c6d0b0aa9a360af8c014156812a8236751a51c81f5fd4637e1bbe1cf44f9ab815e7502a67b522857ed6c72ca13d69d1993b6 SHA512 1d6b85a4a2911c20243f4aa8fe399edc848d540598765df68c83afcd30bd591e7100089e53ccd1bec21aac0be5d8021d6f90a8a0b563612fcfd01a3bd190a9c6
-DIST esptool-4.5.1.tar.gz 6971407 BLAKE2B 8ffc102f5ee854f06156547a46777678df389afbea1229afd1673b26e021a9ec03161e5a1c7fc6fb9b28f6b6a12078c94d9247e351bb46f70b899392aa374d67 SHA512 4b665018eb38796cf785ba0caa20435a1bfa5ad5a50f57207d84242307d354405224ccf216b2cfd8b72602d1f04caa4af38feedc7eb7d8984a1e9e308f8789c4
-DIST esptool-4.6.1.tar.gz 7002756 BLAKE2B 2479c0677ed6a28df2c4c0d13f1905e205a7a1460fe6028194543662a8b646f52e4b9fb5a5a4580a16713b0125fb0121418f5fb3eb8f19b45faa286901ef1dc5 SHA512 610934481246d521fff10a8338e36e046c3b575c6eb615667d42627d2de6941af7d8afe7fee92d0583a1e64338fabaffec6d34f050090ad0d2f6206f525e3049
DIST esptool-4.6.2.tar.gz 7003860 BLAKE2B 051689dbc2194e1ed08467f9ec82e3a48e31cf62c25b83f97e3b05a1d203c9dda120cbb11a40bb61efe076ae8449d0b9b4742b19d59efef205132f05d16130a5 SHA512 97cc9f4d92b479351089fac59aed08f9519ff76d994ddae601da8e39b988f4bb90dc3885bf30b7998e2575a0365a5f0eef85f16a28b12eb944eec1e9f5265c6c
diff --git a/dev-embedded/esptool/esptool-3.3.3.ebuild b/dev-embedded/esptool/esptool-3.3.3.ebuild
deleted file mode 100644
index 8379e418717c..000000000000
--- a/dev-embedded/esptool/esptool-3.3.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1
-
-DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
-HOMEPAGE="https://github.com/espressif/esptool"
-SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/bitstring[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/ecdsa-0.16.0[${PYTHON_USEDEP}]
- dev-python/pyserial[${PYTHON_USEDEP}]
- dev-python/reedsolo[${PYTHON_USEDEP}]
- ')
-"
-BDEPEND="
- $(python_gen_cond_dep '
- dev-python/wheel[${PYTHON_USEDEP}]
- ')
- test? ( $(python_gen_cond_dep '
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/pyelftools[${PYTHON_USEDEP}]
- ') )
-"
-
-python_test() {
- "${EPYTHON}" test/test_imagegen.py || die "imagegen test failed with ${EPYTHON}"
- "${EPYTHON}" test/test_espsecure.py || die "espsecure test failed with ${EPYTHON}"
- "${EPYTHON}" test/test_espefuse_host.py || die "espefuse_host test failed with ${EPYTHON}"
- "${EPYTHON}" test/test_merge_bin.py || die "espefuse_host test failed with ${EPYTHON}"
- # test/test_esptool.py and test/test_espefuse.py need real hardware connected
-}
diff --git a/dev-embedded/esptool/esptool-4.5.1.ebuild b/dev-embedded/esptool/esptool-4.5.1.ebuild
deleted file mode 100644
index 77010ff1b030..000000000000
--- a/dev-embedded/esptool/esptool-4.5.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1
-
-DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
-HOMEPAGE="https://github.com/espressif/esptool"
-SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/bitstring[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/ecdsa-0.16.0[${PYTHON_USEDEP}]
- dev-python/pyserial[${PYTHON_USEDEP}]
- dev-python/reedsolo[${PYTHON_USEDEP}]
- ')
-"
-BDEPEND="
- $(python_gen_cond_dep '
- dev-python/wheel[${PYTHON_USEDEP}]
- ')
- test? ( $(python_gen_cond_dep '
- dev-python/cffi[${PYTHON_USEDEP}]
- dev-python/pyelftools[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- ') )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # test/test_esptool.py and test/test_espefuse.py need real hardware connected
- test/test_esptool.py
- test/test_espefuse.py
-)
-
-src_prepare() {
- default
-
- # test_espsecure_hsm.py needs setup of a "Soft HSM" or real hardware. remove.
- rm test/test_espsecure_hsm.py || die
-}
-
-pkg_postinst() {
- if ver_test ${REPLACING_VERSIONS} -lt 4; then
- ewarn "${P} - new 4.x release with breaking changes:"
- ewarn " - Public API has been defined by limiting access to internals that have been refactored into multiple source files"
- ewarn " - If active security features are detected, the default behavior changes to prevent unintentional bricking"
- ewarn " - Flash parameters in an image header can now be changed only when no SHA256 digest is appended"
- ewarn " - The ESP8684 alias has been removed, ESP32-C2 has to be used"
- ewarn " - Megabit flash sizes have been deprecated, use megabyte units from now on"
- fi
-}
diff --git a/dev-embedded/esptool/esptool-4.6.1.ebuild b/dev-embedded/esptool/esptool-4.6.1.ebuild
deleted file mode 100644
index 152869694986..000000000000
--- a/dev-embedded/esptool/esptool-4.6.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1
-
-DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
-HOMEPAGE="https://github.com/espressif/esptool"
-SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/bitstring[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/ecdsa-0.16.0[${PYTHON_USEDEP}]
- dev-python/pyserial[${PYTHON_USEDEP}]
- dev-python/reedsolo[${PYTHON_USEDEP}]
- ')
-"
-BDEPEND="
- $(python_gen_cond_dep '
- dev-python/wheel[${PYTHON_USEDEP}]
- ')
- test? ( $(python_gen_cond_dep '
- dev-python/cffi[${PYTHON_USEDEP}]
- dev-python/pyaml[${PYTHON_USEDEP}]
- dev-python/pyelftools[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- ') )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # test/test_esptool.py and test/test_espefuse.py need real hardware connected
- test/test_esptool.py
- test/test_espefuse.py
-)
-
-src_prepare() {
- default
-
- # test_espsecure_hsm.py needs setup of a "Soft HSM" or real hardware. remove.
- rm test/test_espsecure_hsm.py || die
-}
-
-pkg_postinst() {
- if ver_test ${REPLACING_VERSIONS} -lt 4; then
- ewarn "${P} - new 4.x release with breaking changes:"
- ewarn " - Public API has been defined by limiting access to internals that have been refactored into multiple source files"
- ewarn " - If active security features are detected, the default behavior changes to prevent unintentional bricking"
- ewarn " - Flash parameters in an image header can now be changed only when no SHA256 digest is appended"
- ewarn " - The ESP8684 alias has been removed, ESP32-C2 has to be used"
- ewarn " - Megabit flash sizes have been deprecated, use megabyte units from now on"
- fi
-}