summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-10-08 09:56:39 +0100
committerMatthew Smith <matthew@gentoo.org>2023-10-08 10:43:36 +0100
commit0bf72d399473ff66a5d4163dd18051b4693070ca (patch)
tree868fd3321a4fb4f12c9438ea2a530caea8c0f7b9 /dev-embedded
parentmedia-sound/ardour: added dependency on net-libs/libwebsockets (diff)
downloadgentoo-0bf72d399473ff66a5d4163dd18051b4693070ca.tar.gz
gentoo-0bf72d399473ff66a5d4163dd18051b4693070ca.tar.bz2
gentoo-0bf72d399473ff66a5d4163dd18051b4693070ca.zip
dev-embedded/picotool: add 1.1.2
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/picotool/Manifest1
-rw-r--r--dev-embedded/picotool/picotool-1.1.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-embedded/picotool/Manifest b/dev-embedded/picotool/Manifest
index be1eb2c00070..b2a8c592757b 100644
--- a/dev-embedded/picotool/Manifest
+++ b/dev-embedded/picotool/Manifest
@@ -1,2 +1,3 @@
DIST pico-sdk-1.4.0.tar.gz 959068 BLAKE2B 95c5e61c4d66c345daa4b8aff8e9e2cd90bcc722289ac67c1a18ce00dfa02ef7fb07512a0fdc7558f989746c215cff31979f1ad8a582e20ff2d151fdd109914f SHA512 4be28cf41e5b808a504b4c949f6c3e9fbc425beb4f838a7898bfd78925cc54e0390ff56c036bc7f60a26efac0d6c1bd811b27f7b60a1c8d7bb4750f3fa37690e
DIST picotool-1.1.0.tar.gz 43994 BLAKE2B 2b8536540be912418be1f0f0d93bb59b9cd4832ce46854478fb0bfbcb4463b49e4806068897a1d665b73ea7a764bf0d96f0a56cde01ef6503c74e1eadc4ed9c2 SHA512 5c13a88e90baed28cf435c7641a84c1c814fc473d57f2502ebb594d84c71bbe82632bf0d24b7755ebfec270d85f4588c488917a224b68c93f40573e956026efc
+DIST picotool-1.1.2.tar.gz 45282 BLAKE2B b7425ae197adef3f72aafa9450338ab1c3ddd4b1a13ff9f4847951ee3d7fd91226f780061416c0d72f963ad0afcf4a14d85c72b6199482738eb5344c8dc6563f SHA512 63e0c77865243aca0b46cb844f5eb104c762d2b38f645c75f32224b61d9768ef0ba59b55d94480559627ec4b23ad6edc49d013f90646644a5dc798090d37a257
diff --git a/dev-embedded/picotool/picotool-1.1.2.ebuild b/dev-embedded/picotool/picotool-1.1.2.ebuild
new file mode 100644
index 000000000000..46993520bd90
--- /dev/null
+++ b/dev-embedded/picotool/picotool-1.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+SDK_PV=1.4.0
+SDK_PN=pico-sdk
+SDK_P=${SDK_PN}-${SDK_PV}
+
+DESCRIPTION="tool for interacting with rp2040 devices and binaries"
+HOMEPAGE="https://github.com/raspberrypi/picotool"
+SRC_URI="
+ https://github.com/raspberrypi/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/raspberrypi/${SDK_PN}/archive/refs/tags/${SDK_PV}.tar.gz -> ${SDK_P}.tar.gz
+"
+
+# picotool (BSD)
+# |- clipp (MIT)
+# |- pico-sdk (BSD)
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPICO_SDK_PATH="${WORKDIR}"/${SDK_P}
+ )
+ cmake_src_configure
+}