summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-16 20:17:57 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-16 20:17:57 +0200
commit4c72b1dce0ed34038d77133cbcdbdc3979c30303 (patch)
treebcf203800e2dfb95cad12f1ae53aaab2c1757c21 /dev-embedded/libdisasm
parentdev-embedded/kobs-ng: Port to EAPI 7 (diff)
downloadgentoo-4c72b1dce0ed34038d77133cbcdbdc3979c30303.tar.gz
gentoo-4c72b1dce0ed34038d77133cbcdbdc3979c30303.tar.bz2
gentoo-4c72b1dce0ed34038d77133cbcdbdc3979c30303.zip
dev-embedded/libdisasm: Port to EAPI 7
Closes: https://bugs.gentoo.org/722606 Closes: https://bugs.gentoo.org/726870 Closes: https://bugs.gentoo.org/742191 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-embedded/libdisasm')
-rw-r--r--dev-embedded/libdisasm/files/libdisasm-0.23-user-AS-OBJDUMP.patch15
-rw-r--r--dev-embedded/libdisasm/libdisasm-0.23.ebuild23
2 files changed, 35 insertions, 3 deletions
diff --git a/dev-embedded/libdisasm/files/libdisasm-0.23-user-AS-OBJDUMP.patch b/dev-embedded/libdisasm/files/libdisasm-0.23-user-AS-OBJDUMP.patch
new file mode 100644
index 000000000000..93e1131b0c81
--- /dev/null
+++ b/dev-embedded/libdisasm/files/libdisasm-0.23-user-AS-OBJDUMP.patch
@@ -0,0 +1,15 @@
+--- a/test/asmdisasm.pl
++++ b/test/asmdisasm.pl
+@@ -22,10 +22,10 @@
+ # uninitialized stuff
+ my ($line, $output);
+
+-system "as --32 -o $obj_file $asm_file";
++system "$ENV{AS} --32 -o $obj_file $asm_file";
+ exit(1) if ($? != 0);
+
+-$output = (grep(/\.text/,`objdump -h $obj_file`))[0];
++$output = (grep(/\.text/,`$ENV{OBJDUMP} -h $obj_file`))[0];
+ $output =~ s/^\s+//g;
+ my ($idx,$name,$size,$vma,$lma,$offset,$align)=split(/\s+/,$output);
+ $size = hex($size);
diff --git a/dev-embedded/libdisasm/libdisasm-0.23.ebuild b/dev-embedded/libdisasm/libdisasm-0.23.ebuild
index 311207917f62..732ccd521c0a 100644
--- a/dev-embedded/libdisasm/libdisasm-0.23.ebuild
+++ b/dev-embedded/libdisasm/libdisasm-0.23.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Provides basic disassembly of Intel x86 instructions from a binary stream"
HOMEPAGE="http://bastard.sourceforge.net/libdisasm.html"
@@ -10,4 +12,19 @@ SRC_URI="mirror://sourceforge/project/bastard/${PN}/${PV}/${P}.tar.gz"
LICENSE="Clarified-Artistic"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-user-AS-OBJDUMP.patch )
+
+src_configure() {
+ # bug 722606
+ tc-export AS OBJDUMP
+
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}