summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/icdprog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/icdprog')
-rw-r--r--dev-embedded/icdprog/Manifest1
-rw-r--r--dev-embedded/icdprog/icdprog-0.5.ebuild36
-rw-r--r--dev-embedded/icdprog/metadata.xml11
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-embedded/icdprog/Manifest b/dev-embedded/icdprog/Manifest
new file mode 100644
index 000000000000..9962a339ae52
--- /dev/null
+++ b/dev-embedded/icdprog/Manifest
@@ -0,0 +1 @@
+DIST icdprog-0.5.tar.gz 47195 SHA256 e863fcf2bd3351be80106b8aa7b4a1a59785de10ad404d34bd0b19f3e445b489 SHA512 3e238cbbbcfc034a5100c78c1e8ffea669deeec26cdf2a2ad1d27577acff1a114badfb67453d4241b9a239326d0d624616fc8383affc3d34380edfdc0fcf7989 WHIRLPOOL f79e4443c22209e8441a2a27588fd8e528167d660d75234e9a7692a24b93e50e1edb56b1cb28f354596e96f49074f8179e73029323987b4599a9e6e067e668fe
diff --git a/dev-embedded/icdprog/icdprog-0.5.ebuild b/dev-embedded/icdprog/icdprog-0.5.ebuild
new file mode 100644
index 000000000000..c8b07aeab3a1
--- /dev/null
+++ b/dev-embedded/icdprog/icdprog-0.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Microchip PIC Programmer using ICD hardware"
+HOMEPAGE="http://icdprog.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+src_compile() {
+ tc-export CC
+
+ cd "${S}"/src
+ emake CFLAGS="${CFLAGS}"
+ cd "${S}"/src/icddump
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin src/icdprog
+ dobin src/icddump/icddump
+ dohtml readme.html
+ dodoc src/README.coders
+}
+
+pkg_postinst() {
+ elog "Please see readme.html if the ICD seems to be very slow."
+}
diff --git a/dev-embedded/icdprog/metadata.xml b/dev-embedded/icdprog/metadata.xml
new file mode 100644
index 000000000000..8984bd587205
--- /dev/null
+++ b/dev-embedded/icdprog/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dev-embedded</herd>
+ <longdescription>ICDPROG is a simple command line programmer for Microchip PIC
+ controllers, using the Microchip ICD (in circuit debugger)
+ hardware.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">icdprog</remote-id>
+ </upstream>
+</pkgmetadata>