summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-10 12:52:05 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-10 17:24:46 +0100
commitad996fed1c81b4db4b2a07dda61451fc87c6713e (patch)
tree92382ea558f861492b293f208aeb0fbec8f552e0 /dev-dotnet/fable
parenteclass/dotnet-pkg.eclass: prepare for safely using Nuget (diff)
downloadgentoo-ad996fed1c81b4db4b2a07dda61451fc87c6713e.tar.gz
gentoo-ad996fed1c81b4db4b2a07dda61451fc87c6713e.tar.bz2
gentoo-ad996fed1c81b4db4b2a07dda61451fc87c6713e.zip
dev-dotnet/fable: leave sln updating (project removal) to the eclass
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet/fable')
-rw-r--r--dev-dotnet/fable/fable-4.11.0.ebuild1
-rw-r--r--dev-dotnet/fable/fable-4.9.0.ebuild5
2 files changed, 2 insertions, 4 deletions
diff --git a/dev-dotnet/fable/fable-4.11.0.ebuild b/dev-dotnet/fable/fable-4.11.0.ebuild
index eaba2e59e7b4..c5f00295612d 100644
--- a/dev-dotnet/fable/fable-4.11.0.ebuild
+++ b/dev-dotnet/fable/fable-4.11.0.ebuild
@@ -347,5 +347,4 @@ src_prepare() {
fi
dotnet-pkg_src_prepare
- edotnet sln ./Fable.sln remove "${DOTNET_PKG_BAD_PROJECTS[@]}"
}
diff --git a/dev-dotnet/fable/fable-4.9.0.ebuild b/dev-dotnet/fable/fable-4.9.0.ebuild
index e564ab360793..6c01e8916011 100644
--- a/dev-dotnet/fable/fable-4.9.0.ebuild
+++ b/dev-dotnet/fable/fable-4.9.0.ebuild
@@ -294,7 +294,7 @@ CHECKREQS_DISK_BUILD="2G"
DOTNET_PKG_PROJECTS=(
src/Fable.Cli/Fable.Cli.fsproj
)
-DOTNET_PKG_REMOVE_PROJECTS=(
+DOTNET_PKG_BAD_PROJECTS=(
src/quicktest/QuickTest.fsproj
tests/Js/Main/Fable.Tests.fsproj
)
@@ -319,12 +319,11 @@ src_prepare() {
rm Fable.Standalone.sln || die
if use debug ; then
- DOTNET_PKG_REMOVE_PROJECTS+=(
+ DOTNET_PKG_BAD_PROJECTS+=(
# Seems to hang but in reality it fails with USE=debug, bug #922684
tests/Python/Fable.Tests.Python.fsproj
)
fi
dotnet-pkg_src_prepare
- edotnet sln ./Fable.sln remove "${DOTNET_PKG_REMOVE_PROJECTS[@]}"
}