summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2022-03-24 07:29:08 +0000
committerPatrick Lauer <patrick@gentoo.org>2022-03-24 07:29:16 +0000
commitd20f93beca38c9cfa9d8d9f23342a5cbf8a2cf72 (patch)
tree566880e6f1ca4b1e70fbf67b08e8eaaa18850b79 /dev-db
parentnet-news/rssguard: drop 4.0.4, add 4.2.1 (diff)
downloadgentoo-d20f93beca38c9cfa9d8d9f23342a5cbf8a2cf72.tar.gz
gentoo-d20f93beca38c9cfa9d8d9f23342a5cbf8a2cf72.tar.bz2
gentoo-d20f93beca38c9cfa9d8d9f23342a5cbf8a2cf72.zip
dev-db/postgresql: Migrate to llvm eclass
Also lock max llvm version to 14 for now Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/postgresql-12.10-r1.ebuild9
-rw-r--r--dev-db/postgresql/postgresql-12.9-r1.ebuild9
-rw-r--r--dev-db/postgresql/postgresql-13.5-r1.ebuild9
-rw-r--r--dev-db/postgresql/postgresql-13.6-r1.ebuild7
-rw-r--r--dev-db/postgresql/postgresql-14.1-r1.ebuild9
5 files changed, 29 insertions, 14 deletions
diff --git a/dev-db/postgresql/postgresql-12.10-r1.ebuild b/dev-db/postgresql/postgresql-12.10-r1.ebuild
index 614645d2a890..3c97b24fd2a4 100644
--- a/dev-db/postgresql/postgresql-12.10-r1.ebuild
+++ b/dev-db/postgresql/postgresql-12.10-r1.ebuild
@@ -4,8 +4,9 @@
EAPI=7
PYTHON_COMPAT=( python3_{8,9,10} )
+LLVM_MAX_SLOT=14
-inherit flag-o-matic linux-info multilib pam prefix python-single-r1 systemd tmpfiles
+inherit flag-o-matic linux-info llvm multilib pam prefix python-single-r1 systemd tmpfiles
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
@@ -36,8 +37,8 @@ icu? ( dev-libs/icu:= )
kerberos? ( virtual/krb5 )
ldap? ( net-nds/openldap:= )
llvm? (
- sys-devel/llvm:=
- sys-devel/clang:=
+ <sys-devel/llvm-15:=
+ <sys-devel/clang-15:=
)
pam? ( sys-libs/pam )
perl? ( >=dev-lang/perl-5.8:= )
@@ -83,6 +84,8 @@ selinux? ( sec-policy/selinux-postgresql )
"
pkg_setup() {
+ llvm_pkg_setup
+
use server && CONFIG_CHECK="~SYSVIPC" linux-info_pkg_setup
use python && python-single-r1_pkg_setup
diff --git a/dev-db/postgresql/postgresql-12.9-r1.ebuild b/dev-db/postgresql/postgresql-12.9-r1.ebuild
index c011d4b2a894..b7d45b34ed5f 100644
--- a/dev-db/postgresql/postgresql-12.9-r1.ebuild
+++ b/dev-db/postgresql/postgresql-12.9-r1.ebuild
@@ -4,8 +4,9 @@
EAPI=7
PYTHON_COMPAT=( python3_{8,9,10} )
+LLVM_MAX_SLOT=14
-inherit flag-o-matic linux-info multilib pam prefix python-single-r1 systemd tmpfiles
+inherit flag-o-matic linux-info llvm multilib pam prefix python-single-r1 systemd tmpfiles
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
@@ -36,8 +37,8 @@ icu? ( dev-libs/icu:= )
kerberos? ( virtual/krb5 )
ldap? ( net-nds/openldap:= )
llvm? (
- sys-devel/llvm:=
- sys-devel/clang:=
+ <sys-devel/llvm-15:=
+ <sys-devel/clang-15:=
)
pam? ( sys-libs/pam )
perl? ( >=dev-lang/perl-5.8:= )
@@ -83,6 +84,8 @@ selinux? ( sec-policy/selinux-postgresql )
"
pkg_setup() {
+ llvm_pkg_setup
+
use server && CONFIG_CHECK="~SYSVIPC" linux-info_pkg_setup
use python && python-single-r1_pkg_setup
diff --git a/dev-db/postgresql/postgresql-13.5-r1.ebuild b/dev-db/postgresql/postgresql-13.5-r1.ebuild
index 71f1f9853dea..d204a6930de0 100644
--- a/dev-db/postgresql/postgresql-13.5-r1.ebuild
+++ b/dev-db/postgresql/postgresql-13.5-r1.ebuild
@@ -4,8 +4,9 @@
EAPI=7
PYTHON_COMPAT=( python3_{8,9,10} )
+LLVM_MAX_SLOT=14
-inherit flag-o-matic linux-info multilib pam prefix python-single-r1 systemd tmpfiles
+inherit flag-o-matic linux-info llvm multilib pam prefix python-single-r1 systemd tmpfiles
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
@@ -36,8 +37,8 @@ icu? ( dev-libs/icu:= )
kerberos? ( virtual/krb5 )
ldap? ( net-nds/openldap:= )
llvm? (
- sys-devel/llvm:=
- sys-devel/clang:=
+ <sys-devel/llvm-15:=
+ <sys-devel/clang-15:=
)
pam? ( sys-libs/pam )
perl? ( >=dev-lang/perl-5.8:= )
@@ -83,6 +84,8 @@ selinux? ( sec-policy/selinux-postgresql )
"
pkg_setup() {
+ llvm_pkg_setup
+
use server && CONFIG_CHECK="~SYSVIPC" linux-info_pkg_setup
use python && python-single-r1_pkg_setup
diff --git a/dev-db/postgresql/postgresql-13.6-r1.ebuild b/dev-db/postgresql/postgresql-13.6-r1.ebuild
index b40f660c6477..166a5befa679 100644
--- a/dev-db/postgresql/postgresql-13.6-r1.ebuild
+++ b/dev-db/postgresql/postgresql-13.6-r1.ebuild
@@ -4,6 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{8,9,10} )
+LLVM_MAX_SLOT=14
inherit flag-o-matic linux-info multilib pam prefix python-single-r1 systemd tmpfiles
@@ -36,8 +37,8 @@ icu? ( dev-libs/icu:= )
kerberos? ( virtual/krb5 )
ldap? ( net-nds/openldap:= )
llvm? (
- sys-devel/llvm:=
- sys-devel/clang:=
+ <sys-devel/llvm-15:=
+ <sys-devel/clang-15:=
)
pam? ( sys-libs/pam )
perl? ( >=dev-lang/perl-5.8:= )
@@ -83,6 +84,8 @@ selinux? ( sec-policy/selinux-postgresql )
"
pkg_setup() {
+ llvm_pkg_setup
+
use server && CONFIG_CHECK="~SYSVIPC" linux-info_pkg_setup
use python && python-single-r1_pkg_setup
diff --git a/dev-db/postgresql/postgresql-14.1-r1.ebuild b/dev-db/postgresql/postgresql-14.1-r1.ebuild
index 5d0ca44d23aa..db0770f6cb90 100644
--- a/dev-db/postgresql/postgresql-14.1-r1.ebuild
+++ b/dev-db/postgresql/postgresql-14.1-r1.ebuild
@@ -4,8 +4,9 @@
EAPI=7
PYTHON_COMPAT=( python3_{8,9,10} )
+LLVM_MAX_SLOT=14
-inherit flag-o-matic linux-info multilib pam prefix python-single-r1 systemd tmpfiles
+inherit flag-o-matic linux-info llvm multilib pam prefix python-single-r1 systemd tmpfiles
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
@@ -36,8 +37,8 @@ icu? ( dev-libs/icu:= )
kerberos? ( virtual/krb5 )
ldap? ( net-nds/openldap:= )
llvm? (
- sys-devel/llvm:=
- sys-devel/clang:=
+ <sys-devel/llvm-15:=
+ <sys-devel/clang-15:=
)
lz4? ( app-arch/lz4 )
pam? ( sys-libs/pam )
@@ -84,6 +85,8 @@ selinux? ( sec-policy/selinux-postgresql )
"
pkg_setup() {
+ llvm_pkg_setup
+
use server && CONFIG_CHECK="~SYSVIPC" linux-info_pkg_setup
use python && python-single-r1_pkg_setup