summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2021-11-23 08:49:11 -0600
committerMatthias Maier <tamiko@gentoo.org>2021-11-23 08:49:46 -0600
commitbadd0bc7e1c65e6d985560a3ed30fd299fac65be (patch)
tree87d70b70653ad509e111f667b07cc357f0ad602e /dev-cpp
parentapp-text/barcode: QA use eautoreconf (diff)
downloadgentoo-badd0bc7e1c65e6d985560a3ed30fd299fac65be.tar.gz
gentoo-badd0bc7e1c65e6d985560a3ed30fd299fac65be.tar.bz2
gentoo-badd0bc7e1c65e6d985560a3ed30fd299fac65be.zip
dev-cpp/cpp-taskflow: QA fixes and add live ebuild
- add a live ebuild as suggested in #733106 - remove 3rd-party directory to make sure that bundled software is not used. Closes: https://bugs.gentoo.org/733106 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild19
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild43
2 files changed, 59 insertions, 3 deletions
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild
index fc6e30fbb60c..e4f2f9e403b5 100644
--- a/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild
+++ b/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild
@@ -7,17 +7,30 @@ inherit cmake
DESCRIPTION="Modern C++ Parallel Task Programming"
HOMEPAGE="https://cpp-taskflow.github.io"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/taskflow-${PV}"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/cpp-taskflow/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+ S="${WORKDIR}/cpp-taskflow-${PV}"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/taskflow-${PV}"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
IUSE="examples test"
RESTRICT="!test? ( test )"
HTML_DOCS=( docs/. )
+src_prepare() {
+ rm -r "${S}/3rd-party" || die "rm failed"
+ default
+ cmake_src_prepare
+}
+
src_configure() {
# TODO: enable CUDA via USE flag
local mycmakeargs=(
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild
new file mode 100644
index 000000000000..e4f2f9e403b5
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/cpp-taskflow-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Modern C++ Parallel Task Programming"
+HOMEPAGE="https://cpp-taskflow.github.io"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/cpp-taskflow/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+ S="${WORKDIR}/cpp-taskflow-${PV}"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/taskflow-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+HTML_DOCS=( docs/. )
+
+src_prepare() {
+ rm -r "${S}/3rd-party" || die "rm failed"
+ default
+ cmake_src_prepare
+}
+
+src_configure() {
+ # TODO: enable CUDA via USE flag
+ local mycmakeargs=(
+ -DTF_BUILD_CUDA=OFF
+ -DTF_BUILD_EXAMPLES=$(usex examples)
+ -DTF_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}