summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2021-04-01 23:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2021-04-02 11:00:48 -0400
commita62ec2473825e637157e1dbfe9efe2d4a95d7c50 (patch)
tree3bc859902606704e318afc84aa5b417be0b1c864 /dev-cpp
parentdev-db/sqlite: Delete old versions (3.33.0, 3.34.0). (diff)
downloadgentoo-a62ec2473825e637157e1dbfe9efe2d4a95d7c50.tar.gz
gentoo-a62ec2473825e637157e1dbfe9efe2d4a95d7c50.tar.bz2
gentoo-a62ec2473825e637157e1dbfe9efe2d4a95d7c50.zip
dev-cpp/glog: Rename "unwind" USE flag to "libunwind". Enable it by default.
Closes: https://bugs.gentoo.org/618190 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/glog/glog-0.3.4-r1.ebuild8
-rw-r--r--dev-cpp/glog/metadata.xml2
2 files changed, 5 insertions, 5 deletions
diff --git a/dev-cpp/glog/glog-0.3.4-r1.ebuild b/dev-cpp/glog/glog-0.3.4-r1.ebuild
index 4a2cfdd6be43..d6fd3e0dc0d4 100644
--- a/dev-cpp/glog/glog-0.3.4-r1.ebuild
+++ b/dev-cpp/glog/glog-0.3.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,12 +12,12 @@ SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 x86 ~amd64-linux ~x86-linux"
-IUSE="gflags static-libs test unwind"
+IUSE="gflags +libunwind static-libs test"
RESTRICT="test"
RDEPEND="
gflags? ( >=dev-cpp/gflags-2.0-r1[${MULTILIB_USEDEP}] )
- unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )"
+ libunwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
test? ( >=dev-cpp/gtest-1.8.0[${MULTILIB_USEDEP}] )"
@@ -37,7 +37,7 @@ multilib_src_configure() {
$(use_enable gflags) \
$(use_enable static-libs static) \
$(use_enable test gtest-config) \
- $(use_enable unwind)
+ $(use_enable libunwind unwind)
}
multilib_src_install_all() {
diff --git a/dev-cpp/glog/metadata.xml b/dev-cpp/glog/metadata.xml
index 3856364cd842..7abf6ed43ca5 100644
--- a/dev-cpp/glog/metadata.xml
+++ b/dev-cpp/glog/metadata.xml
@@ -11,7 +11,7 @@
</maintainer>
<use>
<flag name="gflags">Use <pkg>dev-cpp/gflags</pkg> for flag parsing</flag>
- <flag name="unwind">Use <pkg>sys-libs/libunwind</pkg> for stack unwinding instead of glibc/gcc (may be more reliable on x86_64)</flag>
+ <flag name="libunwind">Use libunwind library (<pkg>sys-libs/libunwind</pkg> or <pkg>sys-libs/llvm-libunwind</pkg>) instead of built-in fallback implementation for stack unwinding</flag>
</use>
<upstream>
<remote-id type="github">google/glog</remote-id>