summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-11 04:32:45 +0000
committerSam James <sam@gentoo.org>2022-01-11 04:33:17 +0000
commit7b00b0d50adbead8ba39f90f90fe27d0b8a4aac6 (patch)
treecc178c273f48815b74e5ebf221de7f9e983ce593 /dev-cpp
parentdev-vcs/stgit: drop old (diff)
downloadgentoo-7b00b0d50adbead8ba39f90f90fe27d0b8a4aac6.tar.gz
gentoo-7b00b0d50adbead8ba39f90f90fe27d0b8a4aac6.tar.bz2
gentoo-7b00b0d50adbead8ba39f90f90fe27d0b8a4aac6.zip
dev-cpp/nlohmann_json: disable docs in 3.10.5
I tried to package the needed bits but they end up needing network at runtime, it seems. Closes: https://bugs.gentoo.org/830862 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild
index 0ac3b7c9dd07..8bc260638ed9 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.10.5.ebuild
@@ -3,6 +3,11 @@
EAPI=8
+#DOCS_BUILDER="mkdocs"
+# Needs unpackaged plantuml-markdown too
+# ... but plantuml (Python bindings anyway) need network access to generate bits at runtime.
+#DOCS_DEPEND="dev-python/mkdocs-material-extensions dev-python/mkdocs-minify-plugin"
+#DOCS_DIR="doc/mkdocs"
inherit cmake
# Check https://github.com/nlohmann/json/blob/develop/cmake/download_test_data.cmake to find test archive version
@@ -17,13 +22,11 @@ S="${WORKDIR}/json-${PV}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE="doc test"
+IUSE="test"
# Need to report failing tests upstream
# Tests only just added, large test suite, majority pass
RESTRICT="test"
-BDEPEND="doc? ( app-doc/doxygen )"
-
DOCS=( ChangeLog.md README.md )
src_configure() {
@@ -41,11 +44,6 @@ src_configure() {
src_compile() {
cmake_src_compile
-
- if use doc; then
- emake -C doc
- HTML_DOCS=( doc/html/. )
- fi
}
src_test() {