summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-27 18:46:15 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-03 18:14:05 -0700
commit36b009f658c94a36ea9029af3de55ef6dc59b8e7 (patch)
treeb699078144abe49c59ced78876e9bc29c7e6b513 /dev-cpp
parentdev-cpp/gtkmm: Switch to meson-multilib (diff)
downloadgentoo-36b009f658c94a36ea9029af3de55ef6dc59b8e7.tar.gz
gentoo-36b009f658c94a36ea9029af3de55ef6dc59b8e7.tar.bz2
gentoo-36b009f658c94a36ea9029af3de55ef6dc59b8e7.zip
dev-cpp/pangomm: Switch to meson-multilib
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/pangomm/pangomm-2.42.2.ebuild16
-rw-r--r--dev-cpp/pangomm/pangomm-2.48.1.ebuild16
2 files changed, 4 insertions, 28 deletions
diff --git a/dev-cpp/pangomm/pangomm-2.42.2.ebuild b/dev-cpp/pangomm/pangomm-2.42.2.ebuild
index d0a2f770d9af..6dbf81680f89 100644
--- a/dev-cpp/pangomm/pangomm-2.42.2.ebuild
+++ b/dev-cpp/pangomm/pangomm-2.42.2.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
-inherit gnome.org meson multilib-minimal python-any-r1
+inherit gnome.org meson-multilib python-any-r1
DESCRIPTION="C++ interface for pango"
HOMEPAGE="https://www.gtkmm.org"
@@ -33,19 +33,7 @@ BDEPEND="
multilib_src_configure() {
local emesonargs=(
- -Dbuild-documentation=$(multilib_native_usex doc true false)
+ $(meson_native_use_bool doc build-documentation)
)
meson_src_configure
}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_install() {
- meson_src_install
-}
-
-multilib_src_test() {
- meson_src_test
-}
diff --git a/dev-cpp/pangomm/pangomm-2.48.1.ebuild b/dev-cpp/pangomm/pangomm-2.48.1.ebuild
index 924043617bfa..a7d98ee56e48 100644
--- a/dev-cpp/pangomm/pangomm-2.48.1.ebuild
+++ b/dev-cpp/pangomm/pangomm-2.48.1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
-inherit gnome.org meson multilib-minimal python-any-r1
+inherit gnome.org meson-multilib python-any-r1
DESCRIPTION="C++ interface for pango"
HOMEPAGE="https://www.gtkmm.org"
@@ -33,19 +33,7 @@ BDEPEND="
multilib_src_configure() {
local emesonargs=(
- -Dbuild-documentation=$(multilib_native_usex doc true false)
+ $(meson_native_use_bool doc build-documentation)
)
meson_src_configure
}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_install() {
- meson_src_install
-}
-
-multilib_src_test() {
- meson_src_test
-}