summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-12-15 12:53:40 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-15 12:53:40 +0100
commit3183337d51ba55a6cd0eaeeb3fff7b13055844a8 (patch)
treeccf21504c34db6a0ab478e04b746761bc7b5fe3b /dev-cpp
parentsci-libs/adolc: Remove old (diff)
downloadgentoo-3183337d51ba55a6cd0eaeeb3fff7b13055844a8.tar.gz
gentoo-3183337d51ba55a6cd0eaeeb3fff7b13055844a8.tar.bz2
gentoo-3183337d51ba55a6cd0eaeeb3fff7b13055844a8.zip
dev-cpp/eigen: Disable cholmod tests through cmake.eclass
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/eigen/eigen-3.3.9.ebuild4
-rw-r--r--dev-cpp/eigen/files/eigen-3.3.9-disable-cholmod_support.patch20
2 files changed, 2 insertions, 22 deletions
diff --git a/dev-cpp/eigen/eigen-3.3.9.ebuild b/dev-cpp/eigen/eigen-3.3.9.ebuild
index 27c31cc35507..58854ef77aaa 100644
--- a/dev-cpp/eigen/eigen-3.3.9.ebuild
+++ b/dev-cpp/eigen/eigen-3.3.9.ebuild
@@ -53,8 +53,6 @@ DEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-3.3.7-gentoo-cmake.patch
"${FILESDIR}"/${PN}-3.3.9-max-macro.patch
- # disable the cholmod tests, they always fail
- "${FILESDIR}"/${PN}-3.3.9-disable-cholmod_support.patch
)
src_prepare() {
@@ -79,6 +77,8 @@ src_configure() {
use test && mycmakeargs+=(
# the OpenGL testsuite is extremely brittle, bug #712808
-DEIGEN_TEST_NO_OPENGL=ON
+ # the cholmod tests are broken and always fail
+ -DCMAKE_DISABLE_FIND_PACKAGE_Cholmod=ON
-DEIGEN_TEST_CXX11=ON
-DEIGEN_TEST_NOQT=ON
-DEIGEN_TEST_ALTIVEC=$(usex cpu_flags_ppc_altivec)
diff --git a/dev-cpp/eigen/files/eigen-3.3.9-disable-cholmod_support.patch b/dev-cpp/eigen/files/eigen-3.3.9-disable-cholmod_support.patch
deleted file mode 100644
index e3b9db5a1707..000000000000
--- a/dev-cpp/eigen/files/eigen-3.3.9-disable-cholmod_support.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/test/CMakeLists.txt
-+++ b/test/CMakeLists.txt
-@@ -46,16 +46,7 @@
-
- set(SPARSE_LIBS " ")
-
--find_package(Cholmod)
--if(CHOLMOD_FOUND)
-- add_definitions("-DEIGEN_CHOLMOD_SUPPORT")
-- include_directories(${CHOLMOD_INCLUDES})
-- set(SPARSE_LIBS ${SPARSE_LIBS} ${CHOLMOD_LIBRARIES} ${EIGEN_BLAS_LIBRARIES} ${EIGEN_LAPACK_LIBRARIES})
-- set(CHOLMOD_ALL_LIBS ${CHOLMOD_LIBRARIES} ${EIGEN_BLAS_LIBRARIES} ${EIGEN_LAPACK_LIBRARIES})
-- ei_add_property(EIGEN_TESTED_BACKENDS "Cholmod, ")
--else()
-- ei_add_property(EIGEN_MISSING_BACKENDS "Cholmod, ")
--endif()
-+ei_add_property(EIGEN_MISSING_BACKENDS "Cholmod, ")
-
- find_package(Umfpack)
- if(UMFPACK_FOUND)