summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-01-19 15:20:52 +0100
committerDavid Seifert <soap@gentoo.org>2019-01-19 15:20:52 +0100
commitd13c7357a618c539ad0bb4de3ecb50bf945fa528 (patch)
tree5550a1ee6b1d0a630e3a84d94a32f67a908fe80f /dev-cpp/catch
parentapp-crypt/libnitrokey: Use SLOTed dev-cpp/catch (diff)
downloadgentoo-d13c7357a618c539ad0bb4de3ecb50bf945fa528.tar.gz
gentoo-d13c7357a618c539ad0bb4de3ecb50bf945fa528.tar.bz2
gentoo-d13c7357a618c539ad0bb4de3ecb50bf945fa528.zip
dev-cpp/catch: Remove old
Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp/catch')
-rw-r--r--dev-cpp/catch/Manifest2
-rw-r--r--dev-cpp/catch/catch-1.11.0.ebuild34
-rw-r--r--dev-cpp/catch/catch-2.2.2.ebuild49
3 files changed, 0 insertions, 85 deletions
diff --git a/dev-cpp/catch/Manifest b/dev-cpp/catch/Manifest
index 2d9261de67d2..9ccecc2df55b 100644
--- a/dev-cpp/catch/Manifest
+++ b/dev-cpp/catch/Manifest
@@ -1,5 +1,3 @@
-DIST Catch-1.11.0.tar.gz 376132 BLAKE2B 23a1a6292dd91ec1c71923b4902b42b59ff6be5227b666f68ef0dc33756a58a63edd70a9b139dda0b1860c2b7a0cfec7ab9262e6447eff3184cfe28ea9b0aa77 SHA512 33085c2671f78c7562eace909564b2730eabcaf4490cd463402e66ab4ac2be1fe4fe360916c11aa589ba4a010622444126ee2ae747783b5869b5d7276361f132
DIST Catch-1.12.2.tar.gz 377265 BLAKE2B bc27b4daee950f8fb93d65f3aed032e72bc856ee27a8dc28c35b89e33f414d68ba4cf00951e476688eddf9e4c0514036bd6916fa6cfa9e3359e6c625984f114f SHA512 ed963cdca9fe307ee02928677f81cafcb41cd607faaa315182fdf898d0f2aa28f0be2141bd642f46fdfac400c38f6d065e00a595a1e5879fe2335c4a3851e844
-DIST Catch2-2.2.2.tar.gz 497244 BLAKE2B d5073d56b9399bd7f50bafc7758e60e31ba4434e229f92ca92cd04257f4a54cec925ad3180cc964c4f69edbaa7fc14f8af8e828421e2bb2b4f6c59eaea5cc06d SHA512 ab91036c6c3ace087d0382ce99f26b2c30a4b75d52f285619ca282a618470fe388afe47495f3b2764268d600c6834c60ba464483d06f3a1c4316c099477c8e38
DIST Catch2-2.3.0.tar.gz 506374 BLAKE2B f692eb0933ca578edf0f15cb83139d2fab03390b3980a686ea495101165d612c848b642ad1e7233bce5bb164c80958c9cbfbc229e72a1ae6947aa4dffdf27556 SHA512 e9a089b504c339e87bda0fb1a4040d9d19c932a4bc7dca41bdad6edfcf8c428f4152ff1e0c898dfdf6b20bd5d901c343bed00ad89351fa5182f3c106e0fb4b03
DIST Catch2-2.5.0.tar.gz 549328 BLAKE2B a32941a043a654228cc541dc675ad789f5b938ebc2d3177d1657f66f68fb175bec8c88a60ecba00e84eca74a7506dc83aed74ac89f7dde83213284eb4a497225 SHA512 420f1d1a5ea7b69be9fb316a8abe1fb7c7e78d44a982e883748f1e0c8d2a435c1518b6022742716019558a740f8b31977ed6a786b0293e0504206b016801cfe8
diff --git a/dev-cpp/catch/catch-1.11.0.ebuild b/dev-cpp/catch/catch-1.11.0.ebuild
deleted file mode 100644
index afc65f924e9f..000000000000
--- a/dev-cpp/catch/catch-1.11.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Modern C++ header-only framework for unit-tests"
-HOMEPAGE="https://github.com/catchorg/Catch2"
-SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${P^}.tar.gz"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-S=${WORKDIR}/${P^}
-
-# CMake is only used to build & run tests, so override phases
-src_configure() { :; }
-src_compile() { :; }
-
-src_test() {
- cmake-utils_src_configure
- cmake-utils_src_compile
- cmake-utils_src_test
-}
-
-src_install() {
- # same location as used in fedora
- insinto /usr/include/catch
- doins -r include/.
- dodoc -r docs/.
-}
diff --git a/dev-cpp/catch/catch-2.2.2.ebuild b/dev-cpp/catch/catch-2.2.2.ebuild
deleted file mode 100644
index 2cce0298b3a4..000000000000
--- a/dev-cpp/catch/catch-2.2.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-inherit cmake-utils python-any-r1
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
-else
- MY_P=${PN^}2-${PV}
- SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-
- S=${WORKDIR}/${MY_P}
-fi
-
-DESCRIPTION="Modern C++ header-only framework for unit-tests"
-HOMEPAGE="https://github.com/catchorg/Catch2"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( ${PYTHON_DEPS} )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2.2-test-python3.patch
- "${FILESDIR}"/${PN}-2.2.2-python-automagic.patch
-)
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCATCH_ENABLE_WERROR=OFF
- -DBUILD_TESTING=$(usex test)
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
- -DPYTHON_EXECUTABLE="${PYTHON}"
- )
- cmake-utils_src_configure
-}